php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70652 Invalid memory access - Unable to reattach to base address
Submitted: 2015-10-06 15:15 UTC Modified: 2015-10-09 10:26 UTC
From: maly at myq dot cz Assigned: ab
Status: Closed Package: opcache
PHP Version: 5.6.14 OS: Windows 10
Private report: No CVE-ID:
 [2015-10-06 15:15 UTC] maly at myq dot cz
Description:
------------
The opcache accesses to invalid address. PHP is running via Apache using mod_fcgid. Php.ini does not contain any plugins (except opcache). 

Eventlog message:

The description for Event ID 487 from source Zend OPcache cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event: 

Unable to reattach to base address
Pokus o přístup k nepřípustné adrese. (translation: A try to access to invalid address)

I have run the attached test script using utility ab.exe:

ab.exe -n 50 -c 3 http://myip/attachedscript.php

This bug is observed in versions 5.6.11-14. Version 5.6.10 seems to work correctly.










Test script:
---------------
<?php
$sec = 3;
echo "waiting $sec s...";

for($i=0; $i < $sec; ++$i) {
	sleep(1);
}

echo "end<br>";
echo "The script has waited for $sec sec";




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-10-07 13:23 UTC] ab@php.net
-Status: Open +Status: Feedback
 [2015-10-07 13:23 UTC] ab@php.net
Thanks for the report. Could you please check some latest 5.6 snapshot? http://windows.php.net/downloads/snaps/php-5.6/ 

Thanks.
 [2015-10-08 08:17 UTC] maly at myq dot cz
-Status: Feedback +Status: Open
 [2015-10-08 08:17 UTC] maly at myq dot cz
I have tried to reproduce this bug in snapshot r07a8e5c (I am unable to download later snapshot) and the bug persists. 

Additional info:
I use non-threadsafe version of PHP (as expected with using mod_fcgid plugin).
 [2015-10-08 08:30 UTC] ab@php.net
-Status: Open +Status: Feedback
 [2015-10-08 08:30 UTC] ab@php.net
Thanks for the checks. However you took too early snapshot. You need one from October 4th or later. With NTS you say, looks like this one could suffice http://windows.php.net/downloads/snaps/php-5.6/r052dd30/ 

Thanks.
 [2015-10-08 08:37 UTC] maly at myq dot cz
-Status: Feedback +Status: Open
 [2015-10-08 08:37 UTC] maly at myq dot cz
I have tried to download php-5.6-nts-windows-vc11-x86-r052dd30.zip and it seems  that the file is corrupted (the size is only 48 kb).
 [2015-10-08 09:34 UTC] ab@php.net
-Status: Open +Status: Feedback
 [2015-10-08 09:34 UTC] ab@php.net
Indeed, some of zips are broken. Here's a hand made snap http://windows.php.net/downloads/snaps/ostc/70652/ from the current dev state, please check.

Thanks.
 [2015-10-08 10:53 UTC] maly at myq dot cz
-Status: Feedback +Status: Open
 [2015-10-08 10:53 UTC] maly at myq dot cz
It seems that issue has disappeared. Now, my tests passed successfully :-).
 [2015-10-09 10:26 UTC] ab@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: ab
 [2015-10-09 10:26 UTC] ab@php.net
@maly thanks for checking! There was a Win10 compatibility fix last week that gives an improvement. It will most likely appear in the next RC, but also next auto snaps (if not broken :)). So i'm closing this now.

Thanks
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Feb 26 21:01:35 2017 UTC