php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70637 PHP errors inside invisible html tag
Submitted: 2015-10-04 17:36 UTC Modified: 2015-10-05 11:44 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: bengusc at gmail dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 7.0.0RC4 OS: Windows 10
Private report: No CVE-ID: None
 [2015-10-04 17:36 UTC] bengusc at gmail dot com
Description:
------------
When a PHP error occurs inside a invisible html tag like `title` it is not able to notify us about this... The html table with error is there but it stay inside that html tag and so it does not take effect.

Test script:
---------------
1. <title><?= ClassName::method(); ?></title>
2. <title><?= ClassName; ?></title>
3. <title><?= function_name(); ?></title>
4. <title><?= $variable_name; ?></title>

5. <title><?= $123; ?></title> (works, the error is shown and out of html tag)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-10-05 09:31 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2015-10-05 09:31 UTC] ab@php.net
Thanks for the report. However it is more related to how you design the error reporting and debug the scripts.

Thanks.
 [2015-10-05 11:44 UTC] bengusc at gmail dot com
I'm trying to make it work using error reporting but no result. Do you have any idea?
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Aug 19 08:04:05 2022 UTC