php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70466 in_array("a", array(0, 1) does not work properly
Submitted: 2015-09-09 02:23 UTC Modified: 2015-09-09 02:44 UTC
From: besciualexandru at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: Arrays related
PHP Version: Next Minor Version OS: CENTOS 5
Private report: No CVE-ID: None
 [2015-09-09 02:23 UTC] besciualexandru at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/function.in-array
---
The script bellow does not behave properly.  Only if you put '0' and '1' as strings it behaves correctly.

Test script:
---------------
if (in_array("a", array(0, 1) )===true){
	echo "'a' is inside array(0,1)";	
} else {
	echo "'a' is NOT inside array(0,1)";
}

Expected result:
----------------
'a' is NOT inside array(0,1)

Actual result:
--------------
'a' is inside array(0,1)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-09-09 02:44 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2015-09-09 02:44 UTC] cmb@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

in_array() does weak comparison by default, and 'a' == 0.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 10 15:01:25 2020 UTC