php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70449 PHP won't compile on 10.4 and 10.5 because of missing constants
Submitted: 2015-09-07 12:56 UTC Modified: 2015-09-07 15:17 UTC
From: willem+php at dvelp dot nl Assigned: bwoebi
Status: Closed Package: Compile Failure
PHP Version: 7.0.0RC2 OS: OSX 10.5
Private report: No CVE-ID:
 [2015-09-07 12:56 UTC] willem+php at dvelp dot nl
Description:
------------
PHP 70 won't build on OSX Leopard (10.5) because it's missing a constant
AI_NUMERICSERV.

/usr/include/netdb.h does not declare AI_NUMERICSERV, the same on Leopard. 
Snow Leopard has AI_NUMERICSERV defined as 0x00001000. 

To reproduce: just compile de code on an older (< 10,6) OSX system which will eventually yeild this error:

php70/work/php-7.0.0RC2/sapi/phpdbg/phpdbg_io.c: In function
"phpdbg_create_listenable_socket":
php70/work/php-7.0.0RC2/sapi/phpdbg/phpdbg_io.c:236: error:
"AI_NUMERICSERV" undeclared (first use in this function)

It would be nice to support older installations so they too can benefit from the
improvements of PHP 7.0.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-09-07 15:17 UTC] laruence@php.net
-Assigned To: +Assigned To: bwoebi
 [2015-09-07 15:29 UTC] bwoebi@php.net
Automatic comment on behalf of bobwei9@hotmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=51272f4217b5961438cf89ac03dc3ab097db8af5
Log: Fixed bug #70449 (PHP won't compile on 10.4 and 10.5 because of missing constants)
 [2015-09-07 15:29 UTC] bwoebi@php.net
-Status: Assigned +Status: Closed
 [2015-09-15 12:13 UTC] ab@php.net
Automatic comment on behalf of bobwei9@hotmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=51272f4217b5961438cf89ac03dc3ab097db8af5
Log: Fixed bug #70449 (PHP won't compile on 10.4 and 10.5 because of missing constants)
 [2016-07-20 11:36 UTC] davey@php.net
Automatic comment on behalf of bobwei9@hotmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=51272f4217b5961438cf89ac03dc3ab097db8af5
Log: Fixed bug #70449 (PHP won't compile on 10.4 and 10.5 because of missing constants)
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Wed Aug 23 00:01:35 2017 UTC