php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70423 Warning Internal error: wrong size calculation
Submitted: 2015-09-03 16:40 UTC Modified: 2015-09-09 16:42 UTC
Votes:3
Avg. Score:3.7 ± 0.5
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:0 (0.0%)
From: ck+php dot net at bbshowcase dot org Assigned: cmb
Status: Closed Package: opcache
PHP Version: master-Git-2015-09-03 (Git) OS: CentOS 7.1
Private report: No CVE-ID:
 [2015-09-03 16:40 UTC] ck+php dot net at bbshowcase dot org
Description:
------------
Was successfully running 7.0RC1 so switched to trunk/master

I consistently get this warning about wrong size calculations

php-fpm using opcache

WARNING: [pool www] child 32223 said into stderr: "Thu Sep  3 11:40:47 2015
 (32223): Warning Internal error: wrong size calculation: 
compat.php start=0x06121740, end=0x06124f18, real=0x06124ef8"

WARNING: [pool www] child 32223 said into stderr: "Thu Sep  3 11:40:47 2015
 (32223): Warning Internal error: wrong size calculation: l10n.php start=0x061e5900, end=0x061e7a50, real=0x061e7a30"

Happens on the same two files consistently, even after a restart.

This appears to be the same problem as Bug #69838 from June-15-2015 which seems to have been patched but maybe not fixed entirely?

http://git.php.net/?p=php-src.git;a=commitdiff;h=f88aad418e4e6fcc91d048446f0892a3ee5b065f



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-09-04 03:17 UTC] laruence@php.net
could you please paste the two files out here?
 [2015-09-04 08:46 UTC] ck+php dot net at bbshowcase dot org
Given their size, how about just direct text links:

http://svn.automattic.com/bbpress/tags/0.9.0.7/bb-includes/l10n.php

http://svn.automattic.com/bbpress/tags/0.9.0.7/bb-includes/compat.php

(I don't see anything special about them but maybe you know better)
 [2015-09-04 10:55 UTC] ck+php dot net at bbshowcase dot org
I should also note, the error only happens ONCE upon php-fpm restart, perhaps when those two scripts are put into the cache the first time?

If I restart php-fpm I can consistently reproduce the error.

The start/end/real numbers change of course.

Maybe somewhat relevant it is in an openvz vps container but in theory that should not affect php?

Happy to test any patch you'd like to try.
 [2015-09-07 12:59 UTC] tm8544 at hotmail dot com
I also see this bug with 7.0.0RC2 x64 TS + Apache/2.4.16 x64 on Windows 10 x64

Error message is shown only on some certain PHP scripts, not all of them. Here is a part of Apache log:

Sun Sep  6 11:28:12 2015 (5668): Warning Internal error: wrong size calculation: D:\HTTPS-SERVER\mysqladm1n007\libraries\user_preferences.lib.php start=0x20775678, end=0x2077d288, real=0x2077d268

Sun Sep  6 11:28:21 2015 (5656): Warning Internal error: wrong size calculation: D:\HTTPS-SERVER\mysqladm1n007\libraries\transformations.lib.php start=0x208c1758, end=0x208cbff0, real=0x208cbfd0

Mon Sep  7 15:50:44 2015 (4904): Warning Internal error: wrong size calculation: D:\HTTPS-SERVER\mysqladm1n007\libraries\user_preferences.lib.php start=0x20755448, end=0x2075d058, real=0x2075d038
 [2015-09-07 13:03 UTC] ab@php.net
Automatic comment on behalf of ab
Revision: http://git.php.net/?p=php-src.git;a=commit;h=eaf96698c7e3229b0217ca3a408fb3b50b9bd333
Log: Fix bug #70423 Warning Internal error: wrong size calculation
 [2015-09-07 13:03 UTC] ab@php.net
-Status: Open +Status: Closed
 [2015-09-07 13:04 UTC] ab@php.net
-Status: Closed +Status: Feedback
 [2015-09-07 13:04 UTC] ab@php.net
@tm8544 please check the latest master.

Thanks.
 [2015-09-07 13:06 UTC] ab@php.net
@"ck+php dot net" #69838 is similar, but this one looks like have been caused by some change after it. Please check now.

Thanks.
 [2015-09-07 13:35 UTC] ck+php dot net at bbshowcase dot org
@ab - Appears to have solved the problem, no more warnings. Many thanks.
 [2015-09-07 14:51 UTC] cmb@php.net
-Status: Feedback +Status: Closed -Assigned To: +Assigned To: cmb
 [2015-09-07 15:11 UTC] ab@php.net
Thanks for the verification )
 [2015-09-09 08:18 UTC] Tm8544 at hotmail dot com
Could you give me a download link to latest master build for win x64 so I can also verify if the problem is gone.
 [2015-09-09 16:42 UTC] cmb@php.net
You can download Windows snapshots from
<http://windows.php.net/snapshots/#php-master> or
<http://windows.php.net/downloads/snaps/master/>.
 [2015-09-09 17:09 UTC] tm8544 at hotmail dot com
I tested with build php-master-ts-windows-vc14-x64-re0f390c

With 7.0.0RC2 Opcache produced internal error:wrong size calculation on some PhpMyAdmin php-scripts.

Now, with this master build, phpmyadmin causes Apache to crash.
Other PHP scripts seems to work as expected.
When I go back to 7.0.0RC1, PhPMyAdmin runs fine.

Pasted from event log:
Viallisen sovelluksen nimi: httpd.exe, versio: 2.4.16.0, aikaleima: 0x55af7bf2
Viallisen moduulin nimi: php7ts.dll, versio: 7.0.0.0, aikaleima: 0x55f01d28
Poikkeuskoodi: 0xc0000005
Virhepoikkeama: 0x000000000021a7ab
Viallisen prosessin tunnus: 0x16f4
Viallisen sovelluksen käynnistysaika: 0x01d0eb20faeea3da
Viallisen sovelluksen polku: C:\Program Files\Apache Software Foundation\Apache24\bin\httpd.exe
Viallisen moduulin polku: C:\PHP\php7ts.dll
Raportin tunnus: 305afb4d-548c-4632-931a-eaee1a9e990e
Viallisen paketin koko nimi: 
Viallisen paketin suhteellinen sovellustunnus: 

Server: W10 pro x64
Apache 2.6.14
PhpMyadmin 4.4.14.1
 [2015-09-09 17:54 UTC] tm8544 at hotmail dot com
Tested again with build php-master-ts-windows-vc14-x64-re0f390c.
This time OpCache was disabled.
Same result with PhpMyAdmin, Apache httpd crashed.
All other PHP applications run as expected.
Strange.
 [2015-09-15 12:13 UTC] ab@php.net
Automatic comment on behalf of ab
Revision: http://git.php.net/?p=php-src.git;a=commit;h=eaf96698c7e3229b0217ca3a408fb3b50b9bd333
Log: Fix bug #70423 Warning Internal error: wrong size calculation
 [2016-07-20 11:36 UTC] davey@php.net
Automatic comment on behalf of ab
Revision: http://git.php.net/?p=php-src.git;a=commit;h=eaf96698c7e3229b0217ca3a408fb3b50b9bd333
Log: Fix bug #70423 Warning Internal error: wrong size calculation
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Tue Aug 29 15:01:52 2017 UTC