php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #7028 xml=shared and wddx do not work together
Submitted: 2000-10-05 01:46 UTC Modified: 2010-08-07 01:47 UTC
From: ipv4 at mail dot ru Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 4.0.3RC2 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ipv4 at mail dot ru
New email:
PHP Version: OS:

 

 [2000-10-05 01:46 UTC] ipv4 at mail dot ru
configure ... --with-xml=shared --enable-wddx

or

--with-xml=shared --enable-wddx=shared

doesn't work. wddx support is always compiled in statically 
and resulting module (or standalone php) becomes unusable as it contains unresolved symbols from xml module.

Currently the only way to build php with xml and wddx is to build xml support statically. :( Is that by design?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-29 04:41 UTC] sniper@php.net
reclassified
 [2000-11-29 08:39 UTC] stas@php.net
I guess yes, this is by design. If you build WDDX, session
module uses it, so you have to build it statically. If you
have WDDX as static, you need XML to be static too, since
WDDX uses XML.

So, while it'd be nice to have such a possibility, currently
it doesn't work by design.

Thus I reclassify it as feature request.
 [2010-07-02 00:15 UTC] gmblar+php at gmail dot com
$ php -r "wddx_deserialize('foo');"

dyld: lazy symbol binding failed: Symbol not found: _XML_ParserCreate
  Referenced from: /usr/lib/php/extensions/no-debug-non-zts-20090626/wddx.so
  Expected in: flat namespace

dyld: Symbol not found: _XML_ParserCreate
  Referenced from: /usr/lib/php/extensions/no-debug-non-zts-20090626/wddx.so
  Expected in: flat namespace

Trace/BPT trap
 [2010-08-07 01:47 UTC] johannes@php.net
-Status: Analyzed +Status: Bogus -Package: Feature/Change Request +Package: *General Issues
 [2010-08-07 01:47 UTC] johannes@php.net
XML stuff was redone in PHP 5.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC