php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70257 timezonedb 2015.6 causes segmentation fault
Submitted: 2015-08-13 02:12 UTC Modified: 2015-08-25 18:40 UTC
Votes:5
Avg. Score:5.0 ± 0.0
Reproduced:5 of 5 (100.0%)
Same Version:2 (40.0%)
Same OS:1 (20.0%)
From: thunberg at gmail dot com Assigned: derick (profile)
Status: Closed Package: timezonedb (PECL)
PHP Version: 5.6.12 OS: AWS Linux
Private report: No CVE-ID: None
 [2015-08-13 02:12 UTC] thunberg at gmail dot com
Description:
------------
I have a cron job set to regularly run the following:

/usr/local/bin/pecl upgrade --ignore-errors timezonedb

Earlier today it picked up the new 2015.6 timezonedb update from PECL and PHP 5.6.10 (at the time installed) immediately started spitting segmentation faults under all cases.

I upgraded to 5.6.12 in an attempt to solve the problem and the issue still persists.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-08-13 03:54 UTC] laruence@php.net
-Assigned To: +Assigned To: derick
 [2015-08-14 10:40 UTC] smemorex at mail2mars dot com
hello,
we have many centos 6 cpanel server with php 5.5.28 ( compiled with easyapache )and timezonedb 2015.6 ( from pecl ) we have segfault of php request with many cms , downgrading timezonedb to 2015.5 we have no problem .

so i can confirm bug with timezonedb 2015.6
 [2015-08-15 05:40 UTC] greenreaper at hotmail dot com
PHP just cut out at midnight server-time (EDT). Loads of segmentation faults. Tried rebuilding a bunch of stuff, no dice. Tracked it down to the timezonedb.so extension, commented it out, server came back up.

PHP 5.6.11 (cli) (built: Aug 15 2015 01:08:46)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend Technologies

Running on FreeBSD 10.1-RELEASE-p16 in a jail.
Ports built with clang36 -O3 with gold linker in case it matters.
 [2015-08-15 07:38 UTC] cont911 at gmail dot com
It looks like the issue caused by condition
#if PHP_VERSION_ID >= 70000
within timezonedb.h (of course when php version is less than 7)

Adding "#define PHP_VERSION_ID 70000" before "#if PHP_VERSION_ID >= 70000" produces correct (no SEGSERV) timezonedb.so.

Checked on PHP 5.5.27, CentOS 6.6
 [2015-08-16 22:00 UTC] derick@php.net
-Status: Assigned +Status: Closed
 [2015-08-16 22:00 UTC] derick@php.net
This should be fixed in both GIT master (and PHP-5.6), and the PECL release 2015.6.1
 [2015-08-25 18:40 UTC] thunberg at gmail dot com
I can confirm this is fixed, thank you.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Aug 23 13:01:27 2019 UTC