php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70229 ./configure --without-sqlite3=/usr
Submitted: 2015-08-10 13:41 UTC Modified: 2015-08-10 14:39 UTC
From: dpa-bugs at aegee dot org Assigned: cmb (profile)
Status: Not a bug Package: SQLite related
PHP Version: 5.5.28 OS:
Private report: No CVE-ID: None
 [2015-08-10 13:41 UTC] dpa-bugs at aegee dot org
Description:
------------
$ php-5.5.28/configure --help
[...]
  --without-sqlite3=DIR   Do not include SQLite3 support. DIR is the prefix to
                          SQLite3 installation directory.
[...]

$ php-5.5.28/configure --without-sqlite3=/usr
configure: error: invalid package name: sqlite3=/usr

The text above suggests, that if --without-sqlite3=DIR is used, then not the bundled libsqlite will be used, but the system-wide installed, as I am looking for option at --help, doing exactly this.

In anycase, according to the --help output, "--without-sqlite3=/usr" is correct, but ./configure does not accept it.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-08-10 14:39 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2015-08-10 14:39 UTC] cmb@php.net
All --without-* options have a --with-* counterpart. Which of
these is shown in the help depends on the defaults (the opposite
is shown). If you don't want to build a certain extension use
--without-NAME, if you want to build a certain extension with a
bundled library (not possible for all extensions) use --with-NAME,
and if you want to build a certain extension with a custom lib use
--with-NAME=/path/to/lib.

So you'll want to try --with-sqlite3=/usr.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Feb 04 16:05:48 2023 UTC