php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7017 ibase_connect and ibase_query
Submitted: 2000-10-04 14:38 UTC Modified: 2000-12-07 11:46 UTC
From: kdogan at simko dot com dot tr Assigned:
Status: Closed Package: InterBase related
PHP Version: 4.0.2 OS: NT 4.0
Private report: No CVE-ID: None
 [2000-10-04 14:38 UTC] kdogan at simko dot com dot tr
...
$myquery = "Select * from myTable";
$db_handle= ibase_connect($host,$username,$password);
$qry_handle = ibase_query($db_handle, $myquery);
/* The last statement does not run, 
the error message is: "Warning: 0 is not a valid InterBase link resource in tes1.php4 on line 15"
if I use same statement without $db_handle, 
like $qry_handle = ibase_query($myquery); 
then ther is no problem.

notes:
php version      : 4.0.2
interbase version: 6.0
OS               : NT 4.0, service pack: 6
Web Server       : IIS 4.0
*/

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-27 23:16 UTC] jah@php.net
This is, I hope, fixed (can't test it because I don't have any Windows machine).You should fetch php4.0.4-dev for win32 from http://www.php4win.de.

Or if you would rather stay with a release version, php4.0.3 for win32 from
the same place and contact me (jah@php.net) directly for an updated version
of php_interbase.dll (thanks to Daniel Beulshausen for compiling it), there was
still one critical InterBase-related bug in 4.0.3.

 [2000-12-07 11:46 UTC] sniper@php.net
No feedback.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Mar 07 16:01:23 2021 UTC