php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70059 FPM does not accept '#' as comment anymore
Submitted: 2015-07-13 06:10 UTC Modified: 2015-07-13 10:06 UTC
From: mfischer@php.net Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 7.0.0beta1 OS: Ubuntu 14.04.2 LTS
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mfischer@php.net
New email:
PHP Version: OS:

 

 [2015-07-13 06:10 UTC] mfischer@php.net
Description:
------------
I'm pretty sure this has changed, as I was running a 5.6 FPM installation with line comments starting with '#' and they didn't work anymore:

[11-Jul-2015 19:30:05] ERROR: [/etc/php5/fpm/pool.d/app.conf:9] value is NULL for a ZEND_INI_PARSER_ENTRY
[11-Jul-2015 19:30:05] ERROR: Unable to include /etc/php5/fpm/pool.d/app.conf from /etc/php5/fpm/php-fpm.conf at line 9
[11-Jul-2015 19:30:05] ERROR: failed to load configuration file '/etc/php5/fpm/php-fpm.conf'
[11-Jul-2015 19:30:05] ERROR: FPM initialization failed

Once I replaced the '#' with a ';' it worked

Maybe it's worth an entry in the Upgrading guide or similar.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-07-13 07:19 UTC] laruence@php.net
-Status: Open +Status: Not a bug
 [2015-07-13 07:19 UTC] laruence@php.net
actually, there is: https://github.com/php/php-src/blob/master/UPGRADING#L425

thanks
 [2015-07-13 10:06 UTC] mfischer@php.net
Thanks, must have slipped past me when I read it, awesome!
 [2021-02-27 09:32 UTC] payalsharma30021 at gmail dot com
Thanks for sharing this post. on-line poker itself has presently become safer numerous to gambling for bettors. you're doing not have to be compelled to worry concerning your profession being discontinuous once enjoying poker gambling.
http://www.bangalore-escort.in/
 [2021-02-27 09:33 UTC] payalsharma30021 at gmail dot com
All around spectacular centres, you created here..Great stuff...I think you've created some truly beguiling core interests. continue the outstanding work.
http://www.sunnyescorts.in
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat May 08 23:01:23 2021 UTC