php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69993 test for gmp.h needs to test w/o include
Submitted: 2015-07-04 01:23 UTC Modified: 2015-09-01 21:03 UTC
Votes:14
Avg. Score:4.0 ± 0.8
Reproduced:14 of 14 (100.0%)
Same Version:10 (71.4%)
Same OS:8 (57.1%)
From: mah at everybody dot org Assigned:
Status: Closed Package: GNU MP related
PHP Version: * OS: Debian
Private report: No CVE-ID:
 [2015-07-04 01:23 UTC] mah at everybody dot org
Description:
------------
The test for gmp.h only tests $i/include/gmp.h exists.  Instead it should test for that OR $i/gmp.h.

Failure to do so results in issues like this one: http://stackoverflow.com/questions/19894168/build-php5-3-8-on-ubuntu-get-error-configure-error-unable-to-locate-gmp-h

I was going to compile php7 and ran into the same problem.  Attached patch fixes this.


Patches

gmp-h-find-fix (last revision 2015-07-04 01:24 UTC) by mah at everybody dot org)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-07-04 10:24 UTC] kalle@php.net
Hi, is this also the case for older versions, like 5.6?
 [2015-07-04 10:26 UTC] kalle@php.net
-Status: Open +Status: Feedback
 [2015-07-05 20:59 UTC] mah at everybody dot org
Given that the code with this issue was checked in 2003 -- https://github.com/php/php-src/blame/master/ext/gmp/config.m4#L7 -- I would say most versions of PHP have this problem.
 [2015-07-12 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2015-07-12 04:31 UTC] requinix@php.net
-Status: No Feedback +Status: Open
 [2015-07-13 22:03 UTC] kalle@php.net
-Status: Open +Status: Verified -PHP Version: 7.0.0alpha2 +PHP Version: *
 [2015-07-13 22:03 UTC] kalle@php.net
Marking this as verified then, should probably only go down to 5.6 since 5.5 and 5.4 is in security only mode
 [2015-09-01 21:03 UTC] cmb@php.net
On a 64bit Debian Jessie libgmp-devel installs gmp.h in
/usr/include/x86_64-linux-gnu/, and so it's not possible to
configure successfully. The supplied patch fixes the issue so
that one can do

  ./configure --disable-all --enable-cli
              --with-gmp=/usr/include/x86_64-linux-gnu
  
However, that looks fishy to me.
 [2017-01-14 13:14 UTC] nikic@php.net
Automatic comment on behalf of jgigov@abv.bg
Revision: http://git.php.net/?p=php-src.git;a=commit;h=60aff0bd30197a4fd898904a45f1677e333a6dda
Log: Fixed bug #69993
 [2017-01-14 13:14 UTC] nikic@php.net
-Status: Verified +Status: Closed
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Fri Jul 28 08:01:47 2017 UTC