php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69987 ReflectionParameter::isCallable not work
Submitted: 2015-07-03 09:45 UTC Modified: 2018-02-23 22:32 UTC
Votes:2
Avg. Score:2.0 ± 1.0
Reproduced:0 of 0 (0.0%)
From: lozinskiy dot artem at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: Reflection related
PHP Version: 5.4Git-2015-07-03 (snap) OS: win7
Private report: No CVE-ID: None
 [2015-07-03 09:45 UTC] lozinskiy dot artem at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/reflectionparameter.iscallable
---
Bug for internal function - callable set_exception_handler ( callable $exception_handler )
not work ReflectionParameter::isCallable

Test script:
---------------
$refl = new ReflectionFunction('set_exception_handler');

$parameters = $refl->getParameters();

var_dump($parameters[0]->getName(), $parameters[0]->isCallable());

Expected result:
----------------
string 'exception_handler' (length=17)
boolean false


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-07-03 12:28 UTC] cmb@php.net
-Status: Open +Status: Verified
 [2015-07-03 12:28 UTC] cmb@php.net
See also the recent discussion on the internals mailing list:
<http://markmail.org/thread/opj5pskqzseqafaz>.
 [2018-02-23 22:32 UTC] cmb@php.net
-Status: Verified +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2018-02-23 22:32 UTC] cmb@php.net
While it is actually the other way round, I'm marking this ticket
as duplicate of bug #72305, since that has already some
explanations and an attached POC.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Jun 19 13:01:26 2019 UTC