php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69973 windows support (build) broken
Submitted: 2015-06-30 17:56 UTC Modified: 2016-12-28 15:16 UTC
Votes:5
Avg. Score:5.0 ± 0.0
Reproduced:5 of 5 (100.0%)
Same Version:4 (80.0%)
Same OS:5 (100.0%)
From: shop1966 at gmail dot com Assigned: cmb (profile)
Status: Closed Package: ssh2 (PECL)
PHP Version: 5.6.10 OS: windows
Private report: No CVE-ID: None
 [2015-06-30 17:56 UTC] shop1966 at gmail dot com
Description:
------------
On http://windows.php.net/downloads/pecl/releases/ssh2/0.12/ the generation of the dll binary zips failed, instead the system drops log zips in http://windows.php.net/downloads/pecl/releases/ssh2/0.12/logs/ with the error logs.


Test script:
---------------
...

Expected result:
----------------
...

Actual result:
--------------
...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-06-30 19:30 UTC] cmb@php.net
-Status: Open +Status: Verified
 [2015-06-30 19:30 UTC] cmb@php.net
FWIW: ssh2 0.12 is not supposed to be compilable on Windows
(MSVC), because 3c44ecf[1] is not contained. I can't fathom why
there are 0.12 DLLs available for PHP 5.3-5.5.

[1] <https://github.com/php/pecl-networking-ssh2/commit/3c44ecf96ff610a9e6d702063cad14add8300383>
 [2015-07-01 05:29 UTC] pajoye@php.net
ssh is supposed to build on windows but is currently broken.

To help maintainers or contributors to fix the issues we do provide logs (build, configure and co) when a build a fail, well, we always provide them :)

Also the description of this issue is wrong.
 [2015-07-01 05:30 UTC] pajoye@php.net
-Summary: 5.6 dll package generation on PECL download failed +Summary: windows support (build) broken
 [2015-07-01 05:30 UTC] pajoye@php.net
change title to match the actual issue
 [2016-02-10 16:11 UTC] anrdaemon at freemail dot ru
I would really like a build of this for 5.6/Windows. I have scripts that rely on SSH connection to perform data gathering.
 [2016-03-22 16:25 UTC] johnmbolton at gmail dot com
Any word when this will be fixed?

Thanks,

John
 [2016-12-28 15:16 UTC] cmb@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: cmb
 [2016-12-28 15:16 UTC] cmb@php.net
Apparently, this issue has been fixed in the meantime.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Jan 23 04:01:24 2020 UTC