php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69960 PHP Fatal error: WINCACHE: lock_writelock: acquired abandoned mutex
Submitted: 2015-06-29 09:47 UTC Modified: 2015-07-16 18:06 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: stefan dot lis dot gmbh at gmail dot com Assigned:
Status: Duplicate Package: WinCache (PECL)
PHP Version: 5.4.42 OS: 2008R2
Private report: No CVE-ID: None
 [2015-06-29 09:47 UTC] stefan dot lis dot gmbh at gmail dot com
Description:
------------
Using WinCache 1.3.7.4
Notice a number of error message regarding abandoned mutex in the php error file.

[16-Jun-2015 06:39:55 Europe/Berlin] PHP Fatal error:  WINCACHE: lock_writelock: acquired abandoned mutex Global\FILELIST_CACHE_5.4_1.3.7.4_1_0_276545_A. Something bad happend in another process! in D:\Moodle\lib\setup.php on line 586

[27-Jun-2015 08:06:22 Europe/Berlin] PHP Fatal error:  Failure in Wincache[3776] allocate_memory: Segment free list corrupt.
 in D:\Moodle\lib\filelib.php on line 1980

[27-Jun-2015 08:39:25 Europe/Berlin] PHP Fatal error:  WINCACHE: lock_writelock: acquired abandoned mutex Global\FILELIST_SEGMENT_5.4_1.3.7.4_1_0_276545_X. Something bad happend in another process! in Unknown on line 0

[27-Jun-2015 08:39:25 Europe/Berlin] PHP Fatal error:  WINCACHE: lock_writelock: acquired abandoned mutex Global\FILELIST_SEGMENT_5.4_1.3.7.4_1_0_276545_X. Something bad happend in another process! in Unknown on line 0



There are also some Windows-Eventlog Errors. But don't fit to the error message date in php-error log.

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="0">1000</EventID> 
  <Level>2</Level> 
  <Task>100</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2015-06-26T05:47:41.000000000Z" /> 
  <EventRecordID>43587</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>LISSVMOODLE01.zdv.liebherr.i</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data>php-cgi.exe</Data> 
  <Data>5.4.42.0</Data> 
  <Data>5553ede6</Data> 
  <Data>php_wincache.dll</Data> 
  <Data>1.3.7.4</Data> 
  <Data>5500a3f0</Data> 
  <Data>c0000005</Data> 
  <Data>000144c8</Data> 
  <Data>12d4</Data> 
  <Data>01d0afc4e2bb46d1</Data> 
  <Data>C:\Program Files (x86)\php\php-cgi.exe</Data> 
  <Data>C:\Program Files (x86)\php\ext\php_wincache.dll</Data> 
  <Data>db470960-1bc6-11e5-8297-0050569614ab</Data> 
  </EventData>
  </Event>

Test script:
---------------
It happen randomly. No test script to demonstrates the bug.

Expected result:
----------------
No crash

Actual result:
--------------
HTTP-Status 500

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-07-16 18:05 UTC] ericsten@php.net
This appears to be duplicate of 68998.
 [2015-07-16 18:06 UTC] ericsten@php.net
-Status: Open +Status: Duplicate
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 03:01:26 2019 UTC