php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6993 uninstalling is a pain in the ass
Submitted: 2000-10-03 09:11 UTC Modified: 2014-12-27 20:47 UTC
Votes:15
Avg. Score:3.7 ± 1.4
Reproduced:11 of 13 (84.6%)
Same Version:1 (9.1%)
Same OS:5 (45.5%)
From: ioquatix at hotmail dot com Assigned: kalle (profile)
Status: Closed Package: *General Issues
PHP Version: 4.0.2 OS: Linux
Private report: No CVE-ID: None
 [2000-10-03 09:11 UTC] ioquatix at hotmail dot com
There is no mention of uninstalling or upgrading php with new modules in the documentation - maybe i'm just having a hardtime trying to reinstall, but there does seem to be a deficiancy...

Also, it would be cool if someone could incorperate make uninstall into the make scripts.

IcK

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-06 16:55 UTC] jmoore@php.net
Cant you just rm the php dir and then make; make install.. thats why I normally do, install to /php-4.0.2 and then symlink /php to it, I can then install 4.0.3 to /php-4.0.3, test it in this dir and then just change the symlink.

What do other people think about this info.. is there any real need for it??

Not really a docu bug.. changing to feature request.

James
 [2010-07-26 10:23 UTC] pajoye@php.net
-Status: Open +Status: To be documented -Package: Feature/Change Request +Package: *General Issues
 [2010-07-26 10:23 UTC] pajoye@php.net
make distclean is available since years.
 [2014-12-27 20:47 UTC] kalle@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: kalle
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Dec 11 11:01:24 2019 UTC