php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #69836 is_numeric and binary number
Submitted: 2015-06-15 12:37 UTC Modified: 2015-06-15 13:39 UTC
From: david at grudl dot com Assigned: cmb (profile)
Status: Duplicate Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2015-06-15 12:37 UTC] david at grudl dot com
Description:
------------
Documentation states that (http://php.net/manual/en/function.is-numeric.php)

> Hexadecimal (e.g. 0xf4c3b00c), Binary (e.g. 0b10100111001), Octal (e.g. 0777) notation is allowed too but only without sign, decimal and exponential part.

But it is not true for binary and octal numbers, is_numeric('0b10100111001') returns FALSE.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-06-15 13:39 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2015-06-15 13:39 UTC] cmb@php.net
This is a duplicate of bug #64877. Nonetheless, thanks for the
reminder.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Mar 04 15:01:24 2021 UTC