php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69828 opcache not normal work
Submitted: 2015-06-14 08:44 UTC Modified: 2015-11-22 04:22 UTC
Votes:5
Avg. Score:4.6 ± 0.8
Reproduced:5 of 5 (100.0%)
Same Version:1 (20.0%)
Same OS:0 (0.0%)
From: xiaoyu at ongod dot org Assigned: dmitry (profile)
Status: No Feedback Package: opcache
PHP Version: 7.0.0alpha1 OS: windows 2008R2 IIS7.5
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2015-06-14 08:44 UTC] xiaoyu at ongod dot org
Description:
------------
When I start zend_extension=php_opcache.dll,then PHP php-cgi.exe down.


模块	FastCgiModule
通知	ExecuteRequestHandler
处理程序	php-7.0.0alpha1
错误代码	0xfffffffe


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-06-14 08:55 UTC] xiaoyu at ongod dot org
-Status: Open +Status: Closed
 [2015-06-14 08:55 UTC] xiaoyu at ongod dot org
re-install is work now.
 [2015-06-14 12:03 UTC] xiaoyu at ongod dot org
-Status: Closed +Status: Assigned
 [2015-06-14 12:03 UTC] xiaoyu at ongod dot org
running some time after still down.

opcache.log

Sun Jun 14 18:13:16 2015 (2828): Fatal Error Unable to reattach to base address
Sun Jun 14 18:13:20 2015 (6496): Fatal Error Unable to reattach to base address
Sun Jun 14 18:14:29 2015 (6124): Fatal Error Unable to reattach to base address
Sun Jun 14 18:18:28 2015 (2468): Fatal Error Unable to reattach to base address
Sun Jun 14 18:18:32 2015 (5952): Fatal Error Unable to reattach to base address
Sun Jun 14 18:18:48 2015 (5252): Fatal Error Unable to reattach to base address
Sun Jun 14 18:21:52 2015 (4676): Fatal Error Unable to reattach to base address
Sun Jun 14 18:21:56 2015 (5020): Fatal Error Unable to reattach to base address
Sun Jun 14 18:22:01 2015 (5112): Fatal Error Unable to reattach to base address
Sun Jun 14 18:28:09 2015 (6248): Fatal Error Unable to reattach to base address
Sun Jun 14 18:28:10 2015 (6148): Fatal Error Unable to reattach to base address
Sun Jun 14 18:28:23 2015 (5828): Fatal Error Unable to reattach to base address
Sun Jun 14 18:28:26 2015 (1232): Fatal Error Unable to reattach to base address
Sun Jun 14 18:28:28 2015 (2784): Fatal Error Unable to reattach to base address
Sun Jun 14 18:28:36 2015 (4524): Fatal Error Unable to reattach to base address
Sun Jun 14 18:28:38 2015 (3192): Fatal Error Unable to reattach to base address
Sun Jun 14 18:28:40 2015 (1464): Fatal Error Unable to reattach to base address
Sun Jun 14 18:28:45 2015 (4728): Fatal Error Unable to reattach to base address
Sun Jun 14 18:29:00 2015 (4852): Fatal Error Unable to reattach to base address
Sun Jun 14 18:29:16 2015 (6628): Fatal Error Unable to reattach to base address
Sun Jun 14 18:29:19 2015 (7036): Fatal Error Unable to reattach to base address
Sun Jun 14 18:29:25 2015 (6412): Fatal Error Unable to reattach to base address
Sun Jun 14 18:34:30 2015 (6436): Fatal Error Unable to reattach to base address
Sun Jun 14 18:37:04 2015 (4380): Fatal Error Unable to reattach to base address
Sun Jun 14 18:37:32 2015 (1664): Fatal Error Unable to reattach to base address
Sun Jun 14 18:40:00 2015 (3160): Fatal Error Unable to reattach to base address
Sun Jun 14 18:42:37 2015 (4852): Fatal Error Unable to reattach to base address
Sun Jun 14 18:43:09 2015 (6828): Fatal Error Unable to reattach to base address
Sun Jun 14 18:43:10 2015 (6764): Fatal Error Unable to reattach to base address
Sun Jun 14 18:46:02 2015 (4404): Fatal Error Unable to reattach to base address
Sun Jun 14 18:46:04 2015 (3392): Fatal Error Unable to reattach to base address
Sun Jun 14 18:47:46 2015 (5340): Fatal Error Unable to reattach to base address
Sun Jun 14 18:50:05 2015 (5620): Fatal Error Unable to reattach to base address
Sun Jun 14 18:55:46 2015 (6628): Fatal Error Unable to reattach to base address
Sun Jun 14 18:58:18 2015 (3316): Fatal Error Unable to reattach to base address
Sun Jun 14 19:06:04 2015 (5768): Fatal Error Unable to reattach to base address
Sun Jun 14 19:09:04 2015 (6240): Fatal Error Unable to reattach to base address
Sun Jun 14 19:09:09 2015 (6088): Fatal Error Unable to reattach to base address
Sun Jun 14 19:09:12 2015 (5828): Fatal Error Unable to reattach to base address
Sun Jun 14 19:09:24 2015 (3808): Fatal Error Unable to reattach to base address
Sun Jun 14 19:09:28 2015 (5936): Fatal Error Unable to reattach to base address
Sun Jun 14 19:09:41 2015 (5524): Fatal Error Unable to reattach to base address
Sun Jun 14 19:09:43 2015 (1428): Fatal Error Unable to reattach to base address
Sun Jun 14 19:09:46 2015 (908): Fatal Error Unable to reattach to base address
Sun Jun 14 19:09:53 2015 (4432): Fatal Error Unable to reattach to base address
Sun Jun 14 19:09:55 2015 (2280): Fatal Error Unable to reattach to base address
Sun Jun 14 19:10:08 2015 (6416): Fatal Error Unable to reattach to base address
Sun Jun 14 19:10:41 2015 (5836): Fatal Error Unable to reattach to base address
Sun Jun 14 19:11:01 2015 (1380): Fatal Error Unable to reattach to base address
Sun Jun 14 19:11:02 2015 (7088): Fatal Error Unable to reattach to base address
Sun Jun 14 19:11:07 2015 (6920): Fatal Error Unable to reattach to base address
Sun Jun 14 19:11:08 2015 (4244): Fatal Error Unable to reattach to base address
Sun Jun 14 19:11:13 2015 (5248): Fatal Error Unable to reattach to base address
Sun Jun 14 19:11:13 2015 (6396): Fatal Error Unable to reattach to base address
Sun Jun 14 19:11:16 2015 (6040): Fatal Error Unable to reattach to base address
Sun Jun 14 19:11:43 2015 (6632): Fatal Error Unable to reattach to base address
Sun Jun 14 19:11:46 2015 (6976): Fatal Error Unable to reattach to base address
Sun Jun 14 19:15:49 2015 (4516): Fatal Error Unable to reattach to base address
Sun Jun 14 19:15:50 2015 (6964): Fatal Error Unable to reattach to base address
Sun Jun 14 19:21:35 2015 (4136): Fatal Error Unable to reattach to base address
Sun Jun 14 19:21:35 2015 (6244): Fatal Error Unable to reattach to base address
Sun Jun 14 19:21:35 2015 (6252): Fatal Error Unable to reattach to base address
Sun Jun 14 19:21:36 2015 (6180): Fatal Error Unable to reattach to base address
Sun Jun 14 19:21:37 2015 (3256): Fatal Error Unable to reattach to base address
Sun Jun 14 19:21:37 2015 (4636): Fatal Error Unable to reattach to base address
Sun Jun 14 19:21:37 2015 (3500): Fatal Error Unable to reattach to base address
Sun Jun 14 19:21:37 2015 (3912): Fatal Error Unable to reattach to base address
Sun Jun 14 19:21:38 2015 (4884): Fatal Error Unable to reattach to base address
Sun Jun 14 19:21:38 2015 (6540): Fatal Error Unable to reattach to base address
Sun Jun 14 19:21:38 2015 (6588): Fatal Error Unable to reattach to base address
Sun Jun 14 19:21:38 2015 (4816): Fatal Error Unable to reattach to base address
Sun Jun 14 19:23:48 2015 (4988): Fatal Error Unable to reattach to base address
Sun Jun 14 19:31:07 2015 (7032): Fatal Error Unable to reattach to base address
Sun Jun 14 19:32:21 2015 (4936): Fatal Error Unable to reattach to base address
Sun Jun 14 19:38:20 2015 (5644): Fatal Error Unable to reattach to base address
Sun Jun 14 19:48:30 2015 (5760): Fatal Error Unable to reattach to base address
Sun Jun 14 19:50:17 2015 (5648): Fatal Error Unable to reattach to base address
Sun Jun 14 19:52:59 2015 (6084): Fatal Error Unable to reattach to base address
Sun Jun 14 19:53:04 2015 (2828): Fatal Error Unable to reattach to base address
Sun Jun 14 19:53:07 2015 (6200): Fatal Error Unable to reattach to base address
Sun Jun 14 19:58:24 2015 (4008): Fatal Error Unable to reattach to base address
Sun Jun 14 20:00:48 2015 (4784): Fatal Error Unable to reattach to base address
Sun Jun 14 20:00:49 2015 (6704): Fatal Error Unable to reattach to base address
Sun Jun 14 20:00:54 2015 (6968): Fatal Error Unable to reattach to base address
Sun Jun 14 20:00:56 2015 (5348): Fatal Error Unable to reattach to base address
 [2015-06-14 12:04 UTC] laruence@php.net
-Status: Assigned +Status: Feedback
 [2015-06-14 12:04 UTC] laruence@php.net
设置: opcache.mmap_base  参看 https://github.com/zendtech/ZendOptimizerPlus 中的readme
(you need to set opcache.mmap_base, refer to https://github.com/zendtech/ZendOptimizerPlus)
 [2015-06-14 14:05 UTC] xiaoyu at ongod dot org
-Status: Feedback +Status: Open
 [2015-06-14 14:05 UTC] xiaoyu at ongod dot org
OK. I have see and try it. but what is right value for opcache.mmap_base ? I still no find about this. why I using PHP5.6 no need setup this? PHP5.6 normal work.
 [2015-06-14 15:32 UTC] ab@php.net
-Status: Open +Status: Feedback
 [2015-06-14 15:32 UTC] ab@php.net
@xiaoyu you have to play with the value, please check bug #64926 and maybe this ticket https://github.com/zendtech/ZendOptimizerPlus/issues/167 .

Thanks.
 [2015-06-14 17:35 UTC] xiaoyu at ongod dot org
-Status: Feedback +Status: Open
 [2015-06-14 17:35 UTC] xiaoyu at ongod dot org
I have try config the opcache.mmap_base=0x0000300000000000  or other number. but it is still down when run some time.


I change back to PHP5.6.10 is work. why I have no setup any opcache.mmap_base in PHP5.6.10,it is work.
 [2015-06-17 07:42 UTC] kalle@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: dmitry
 [2015-06-17 07:42 UTC] kalle@php.net
Dmitry, any input here?
 [2015-08-24 12:19 UTC] quantuumsnot at gmail dot com
Same problem for me too. CLI continues to stop working when opcache is enabled
Windows 7 x64, PHP 7.0.0RC1-VC14 x64 Thread Safe
 [2015-11-10 23:18 UTC] ab@php.net
-Status: Assigned +Status: Feedback
 [2015-11-10 23:18 UTC] ab@php.net
This was fixed in RC4, but please try the latest with opcache.file_cache=1 and opcache.file_cache_fallback=1 . When reattach was failed, it'll use file cache as fallback.

Thanks.
 [2015-11-22 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Sep 15 14:01:27 2019 UTC