php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69818 FPM children never idle
Submitted: 2015-06-13 12:32 UTC Modified: 2015-06-25 12:50 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: derkontrollfreak+9hy5l at gmail dot com Assigned:
Status: Closed Package: FPM related
PHP Version: 7.0.0alpha1 OS: Debian 8.1 amd64
Private report: No CVE-ID: None
 [2015-06-13 12:32 UTC] derkontrollfreak+9hy5l at gmail dot com
Description:
------------
__configure line__
./configure --prefix=$HOME/local/php \
    --disable-cgi \
    --disable-cli \
    --enable-fpm \
    --disable-all \
    --without-pear

__runtime configuration__
Using default FPM configuration files etc/php-fpm.conf.default and etc/php-fpm.d/www.conf.default (log_level changed to debug).

__bug__
Immediately after starting php-fpm pm.max_children processes are spawned and never killed. There are no incoming connections.

__php-fpm.log__
http://pastebin.com/3T1Z205S


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-06-25 12:50 UTC] derkontrollfreak+9hy5l at gmail dot com
-Status: Open +Status: Closed
 [2015-06-25 12:50 UTC] derkontrollfreak+9hy5l at gmail dot com
Seems to be fixed in 7.0.0alpha2.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 10 05:05:46 2022 UTC