php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69638 Class does not return expected result
Submitted: 2015-05-15 07:58 UTC Modified: 2015-05-15 11:04 UTC
From: camilleri dot jon at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: Documentation problem
PHP Version: 5.6.9 OS: Windows 8
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: camilleri dot jon at gmail dot com
New email:
PHP Version: OS:

 

 [2015-05-15 07:58 UTC] camilleri dot jon at gmail dot com
Description:
------------
I am using Adobe Dreamweaver CS3, and, trying out sample code from http://php.net/manual/en/intro-whatcando.php, however, it appears that the html sample provided is not returning any information from the class exemplified.

I tried on Google Chrome and IE11.

Is this a browser specific issue?

<html>

<head>



</head>

<body>

<p>

<? php

class Vehicle {

public function hok()

}

$bicycle = new Bicycle();

echo $bicycle->honk();

</p>

</body>

</html> 



Test script:
---------------
One has to use manual testing with the sample code provided in the previous field, in order to allow me to proceed.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-05-15 11:04 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2015-05-15 11:04 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

The contributed example seems pretty useless (it also has been voted down by -55).
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Mar 09 07:01:23 2021 UTC