php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69623 BC: Namespaces now case-sensitive
Submitted: 2015-05-11 19:38 UTC Modified: 2017-08-17 16:56 UTC
From: anna at foolab dot ca Assigned: cmb (profile)
Status: Not a bug Package: Scripting Engine problem
PHP Version: master-Git-2015-05-11 (Git) OS: OSX 10.10.2
Private report: No CVE-ID: None
 [2015-05-11 19:38 UTC] anna at foolab dot ca
Description:
------------
PHP 7.0.0-dev

Namespaces used to be case insensitive in PHP 5.6, but they are case sensitive now. Not sure if the desired behavior, but will cause fatal errors if there is a case mismatch.

Example: Acme\Sitebundle will not be found in the folder is named Acme/SiteBundle


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-05-12 11:22 UTC] cmb@php.net
-Status: Open +Status: Feedback -Package: *General Issues +Package: Scripting Engine problem
 [2015-05-12 11:22 UTC] cmb@php.net
The case-insensitivity of namespaces is supposed to be kept for
PHP 7.0.0. I can't reproduce any change in this regard with latest
master (06ef3aa6b0), see <http://3v4l.org/vPR24> for the code I
used.

With regard to autoloading, I can't detect a behavioral change,
either. The namespace identifier is passed to the autoload
function in the letter case its written in the source code (see
<http://3v4l.org/Am1Fv>).

Can you please post a test script that shows the behavior you're
reporting. Please mention the commit you're testing with.
 [2015-05-22 17:50 UTC] anna at foolab dot ca
Thanks for the reply. I investigated further and it turns out that the issue resided in filepath case-sensitivity differences between Debian and OSX. Nothing to do with PHP7. You can close the report.
 [2015-05-24 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2017-08-17 16:56 UTC] cmb@php.net
-Status: No Feedback +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2017-08-17 16:56 UTC] cmb@php.net
> Nothing to do with PHP7. You can close the report.

Fine.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Apr 25 22:01:25 2019 UTC