php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69600 Problem print out table view
Submitted: 2015-05-08 05:43 UTC Modified: 2015-05-08 05:46 UTC
From: erik at bbk dot go dot id Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.5.24 OS: ubuntu
Private report: No CVE-ID: None
 [2015-05-08 05:43 UTC] erik at bbk dot go dot id
Description:
------------
html>
<head>
     <base href="<?=base_url();?>" />
     <!--<link rel="stylesheet" type="text/css" href="css/print3.css" media="screen, projection" />-->
    
</head>
<body onLoad="window.print()" style="background-color:#FFF" style="font-family:Verdana, Geneva, sans-serif">
   	<div>
	<table border="0" cellpadding="0" cellspacing="0" width="100%">
		<tr>
       			<td width="125"><font size="2"></td>
			<td width="5"><font size="1"></td>
			<td colspan="2" align=right><font size="2">
			Bandung,&nbsp;<?=tgl_indo(date($tgl_invoice));?></td>
		</tr>
		<tr>
       			<td width="125" align=left colspan="4">Kepada Yth.</td>				    
		</tr>
		
		<tr>
       			<td width="125" align=left colspan="4"><?=$nama_customer?></b></td>
		</tr>
		<tr>
       			<td width="125" align=left colspan="4">di</td>				    
		</tr>
		<tr>
       			<td width="125" align=left colspan="4">&nbsp;&nbsp;&nbsp;<?=$kota?></b></td>
		</tr>
		<tr>
       			<td colspan="4" height="80"><?=$this->judul;?></td>
		</tr>
		
		<tr>
       			<td colspan="4" height="80">Invoice ke : <?=$invoice_ke?></br>No. Order  : <?=$no_order?></td>
		</tr>
		
		
	</table>
	</div>
	<div>
                     <? $buffer='';
		if($result){			
			$buffer=$this->load->view('cetak/print_view_detail_invoice.php','',true);			
			$buffer = str_replace('border="0"','border="1"',$buffer);
			$buffer = str_replace('class="c-table-xa"','style="font-weight:bold; background-color:#aaa;"',$buffer);
			$buffer = strip_tags($buffer,"<table><tr><td><p><h1><h2><h3><b><div><li>");
			echo $buffer;
		}
		?>
        </div>	
	<div>
	<table  width="100%" border="0" >
	<tr>
		<td align="center" style="padding-top:15px">
		<div>
           	 <? $buffer='';
			if($resultbiaya_lain){ 
			$buffer = $this->load->view('cetak/print_view_biaya_lain.php');
			$buffer = str_replace('border="0"','border="1"',$buffer);
			$buffer = str_replace('class="c-table-xa"','style="font-weight:bold; background-color:#aaa;"',$buffer);
			$buffer = strip_tags($buffer,"<table><tr><td><p><h1><h2><h3><b><div><li>");
			echo $buffer;
			}
	   	 ?>
		</div>
         	</td>
  	</tr>
	<tr>
		<td>&nbsp;</td>
	</tr>
		
  	<tr>
        	<td width="100" valign="top" class="input-text-1" 
		    style="padding-left:10px; text-align:right; vertical-align:text-top">       			 
       			<div>Discount : <b><?=formatRupiah($discount);?></b></div>
			<div>Ppn 10%    : <b><?=formatRupiah($ppn);?></b></div>
        		<div  style="text-align:right">Jumlah Total : <b><?=formatRupiah($harga_total);?></b> </div><br>
      		</td>

  	</tr>
	<tr>
        	<td width="100" valign="top" class="input-text-1" 
		    style="padding-left:10px; text-align:right; vertical-align:text-top">       			 
       			<div>Jumlah Bayar : <b><?=formatRupiah($jumlah_bayar);?></b></div>
			<div>Sisa Bayar  : <b><?=formatRupiah($sisa_bayar);?></b></div><br>
      		</td>

  	</tr>
	<tr>
		<td>
		<div><font>Keterangan :<br><br> 
       1. Pembayaran dapat ditransfer ke Bank BNI 46 Cabang A. Yani Bandung dengan No. Rek. 0021753620 a.n BPn 022 Balai Besar Keramik<br>
	     2. Pembayaran melalui transfer bank, agar mencantumkan Nama Perusahaan dan No.Order, dengan jumlah bersih sesuai tagihan diluar biaya administrasi bank.<br>
	     3. Bukti Setoran agar difax ke (022) 7205322 atau e-mail: bendahara_pnbp@keramik.go.id / bbkpnbp@gmail.com<br>
		
	</div> 
		</td>
	</tr>
	</div>
	<div>
	        <table  width="100%" border="0" style=" border:none;">
		</br></br>
		<tr>
		</tr>	
		<tr>
			<td align="center"  width="33"></td>
			<td width="33"></td>
			<td align="center"  width="33">Ka. Subag Keuangan</td>
			<!--<td align="center"  width="33">Bendahara Penerimaan PNBP</td>-->
		</tr>
		<tr>
			<td align="center"  width="33"></td>
			<td width="33"></td>
			<td align="center"  width="33"><?=$nama_satker;?></td>
		</tr>
		<tr height="45">
			<td width="33"></td>
			<td width="33"></td>
			<td width="33"></td>
		</tr>
		<tr>
			<td align="center" width="33"></td>
			<td width="33"></td>
			<td align="center"  width="33">Dwi Ariyani<br>(198308132008032001)</td>
			<!--<td align="center"  width="33">(<?=$nama_pembuat_invoice;?>)</br><?=$nip_pembuat_invoice;?></td>-->
		</tr>
	       </table>
	</div>
</body>
</html>

Test script:
---------------
View bug in attachment

Expected result:
----------------
position table is strange in php 5.5


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-05-08 05:46 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2015-05-08 05:46 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Make sure you have short_open_tag enabled, or use the long form <?php.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Aug 09 20:05:45 2022 UTC