php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6943 flush() doesn't flush before the end of the PHP script exuction
Submitted: 2000-09-29 17:02 UTC Modified: 2000-11-09 06:21 UTC
From: denis dot roux at alcatel dot fr Assigned:
Status: Closed Package: Output Control
PHP Version: 4.0.2 OS: Windows NT 4.0
Private report: No CVE-ID: None
 [2000-09-29 17:02 UTC] denis dot roux at alcatel dot fr
<html>
<head>
<title>Exemple</title>
</head>
<body>
<?
echo ("script PHP");
echo "should be printed immediatly<br>"; 
flush();
?>  
hello<br>
<?>                      
sleep(3); 
 echo "in fact, printed in the same time that, i.e. after the 3sec. delay !!!"; 
</script>
</body>
</html>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-09 06:21 UTC] hholzgra@php.net
this is most likely your webserver thats buffering the whole
output from php and doesn't send it out before script 
completion
 [2002-05-22 10:19 UTC] mrusso69 at hotmail dot com
To bring this back from the dead! I have been searching on how to fix this for 2 days now.  I understand that it's probably a problem with the webserver, and apologize for putting this here, but does anybody know how to get around this?  I have a php script that I'm running from a command line, and the output doesn't show till the script ends.  The problem is, this script doesn't end.  It keeps running every 15 minutes.  I'm sorry that this isn't a php problem, but a webserver problem, but I'm out of ideas on how to fix it :(

Thanks
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Sep 19 15:01:25 2020 UTC