php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #69278 HTTP2 support
Submitted: 2015-03-22 22:47 UTC Modified: 2015-06-22 11:03 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: masakielastic at gmail dot com Assigned: kalle
Status: Closed Package: cURL related
PHP Version: master-Git-2015-03-22 (Git) OS: Mac OS X
Private report: No CVE-ID:
 [2015-03-22 22:47 UTC] masakielastic at gmail dot com
Description:
------------
cURL upports HTTP2 via nghttp2 (--with-nghttp2) since 7.33.0 and later. CURL_HTTP_VERSION_2_0 and CURL_VERSION_HTTP2 were added in 7.33.0.

http://curl.haxx.se/dev/readme-http2.html
https://github.com/bagder/curl/blob/1f651d1d4d6d3b6c05e2ebf229ccd10ae2af1991/docs/libcurl/symbols-in-versions

CURL_HTTP_VERSION_2_0 definition
https://github.com/bagder/curl/blob/1f651d1d4d6d3b6c05e2ebf229ccd10ae2af1991/include/curl/curl.h#L1681
CURL_VERSION_HTTP2 definition
https://github.com/bagder/curl/blob/1f651d1d4d6d3b6c05e2ebf229ccd10ae2af1991/include/curl/curl.h#L2276


Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-06-22 11:03 UTC] kalle@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: kalle
 [2015-06-22 11:03 UTC] kalle@php.net
Closing, this was merged already
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Mon Feb 27 04:01:38 2017 UTC