php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69251 opcache.enable_cli=1 -> zend_mm_heap corrupted
Submitted: 2015-03-17 20:16 UTC Modified: 2021-07-18 04:22 UTC
Votes:10
Avg. Score:4.1 ± 0.9
Reproduced:8 of 9 (88.9%)
Same Version:2 (25.0%)
Same OS:4 (50.0%)
From: me at fixxxer dot me Assigned: cmb (profile)
Status: No Feedback Package: opcache
PHP Version: 5.6.6 OS: Linux x86_64
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: me at fixxxer dot me
New email:
PHP Version: OS:

 

 [2015-03-17 20:16 UTC] me at fixxxer dot me
Description:
------------
Set opcache.enable_cli=1. Install Composer (I use version 1.0-dev (829199c0530ea131262c804924f921447c71d4e8)), and create a new laravel 5 project with:

composer create-project laravel/laravel --prefer-dist

...Generating optimized class loader
Compiling common classes
Application key [] set successfully.
zend_mm_heap corrupted

No issues with opcache.enable_cli=0.

Exact versions of libraries installed by composer do not seem to matter, according to google search people have encountered the same issue with earlier versions: https://github.com/laravel/framework/issues/6721 etc


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-07-08 11:26 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2021-07-08 11:26 UTC] cmb@php.net
Is this still an issue with any of the actively supported PHP
versions[1]?

[1] <https://www.php.net/supported-versions.php>
 [2021-07-18 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Jul 23 17:01:23 2021 UTC