php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69251 opcache.enable_cli=1 -> zend_mm_heap corrupted
Submitted: 2015-03-17 20:16 UTC Modified: -
Votes:9
Avg. Score:4.2 ± 0.9
Reproduced:7 of 8 (87.5%)
Same Version:2 (28.6%)
Same OS:4 (57.1%)
From: me at fixxxer dot me Assigned:
Status: Open Package: opcache
PHP Version: 5.6.6 OS: Linux x86_64
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2015-03-17 20:16 UTC] me at fixxxer dot me
Description:
------------
Set opcache.enable_cli=1. Install Composer (I use version 1.0-dev (829199c0530ea131262c804924f921447c71d4e8)), and create a new laravel 5 project with:

composer create-project laravel/laravel --prefer-dist

...Generating optimized class loader
Compiling common classes
Application key [] set successfully.
zend_mm_heap corrupted

No issues with opcache.enable_cli=0.

Exact versions of libraries installed by composer do not seem to matter, according to google search people have encountered the same issue with earlier versions: https://github.com/laravel/framework/issues/6721 etc


Patches

Add a Patch

Pull Requests

Add a Pull Request

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Dec 10 02:01:24 2019 UTC