php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69247 Arrays in classes can't have more than 32767 items
Submitted: 2015-03-17 12:06 UTC Modified: 2015-03-17 15:30 UTC
Votes:3
Avg. Score:5.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: david at grudl dot com Assigned:
Status: Duplicate Package: Compile Failure
PHP Version: 5.6.6 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
22 - 2 = ?
Subscribe to this entry?

 
 [2015-03-17 12:06 UTC] david at grudl dot com
Description:
------------
When an array defined in class (static or non-static) contains more than 32767 items with string keys, its content is silently discarded.

This bug affects all 5.6.x releases.



Test script:
---------------
https://gist.github.com/dg/e785ed8fcef9ee0d5141


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-03-17 13:08 UTC] laruence@php.net
struct _zend_ast {
 unsigned short kind;
 unsigned short children;  <---- 

I don't think fix this is okey due to ABI BC break....

:<
 [2015-03-17 13:09 UTC] laruence@php.net
-Status: Open +Status: Analyzed
 [2015-03-17 13:55 UTC] laruence@php.net
I'd like mark this as won't fix , and master(php7) works fine... objections?
 [2015-03-17 15:30 UTC] nikic@php.net
-Status: Analyzed +Status: Duplicate
 [2015-03-17 15:30 UTC] nikic@php.net
Duplicate of https://bugs.php.net/bug.php?id=68057.

And yes, I agree that we probably can't fix that one in PHP 5.6.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Jun 19 19:01:26 2019 UTC