php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69148 Class member malfunction
Submitted: 2015-02-28 21:33 UTC Modified: 2015-03-26 12:26 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: ordinaryparksee at gmail dot com Assigned:
Status: Not a bug Package: pthreads (PECL)
PHP Version: 5.6Git-2015-02-28 (snap) OS: Ubuntu14.10 Server
Private report: No CVE-ID: None
 [2015-02-28 21:33 UTC] ordinaryparksee at gmail dot com
Description:
------------
Different result return between extending Thread class and not.

Test script:
---------------
<?php
class Test extends Thread
{
    protected $member;
    public function __construct($member = null)
    {
        $this->member = $member;
        $this->member->text = 'changed text';
    }
}
class Text
{
    public $text = 'this is text';
}
$text = new Text();
$test = new Test($text);
echo $text->text.PHP_EOL;

Expected result:
----------------
changed text

Actual result:
--------------
this is text

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-03-02 00:23 UTC] cmbecker69 at gmx dot de
This is not a bug.

Please consult the pthreads documentation on php.net[1] and
consider to ask for support on an appropriate mailing list or
newsgroup[2] or another support forum.

[1] <http://php.net/manual/en/book.pthreads.php>
[2] <http://php.net/support.php>
 [2015-03-26 12:26 UTC] cmb@php.net
-Status: Open +Status: Not a bug
 [2015-03-26 12:26 UTC] cmb@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Feb 23 23:01:26 2019 UTC