php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68983 pecl tarball file for PDO_OCI can not be decompressed
Submitted: 2015-02-04 17:24 UTC Modified: 2015-02-04 18:55 UTC
From: amosbatto at yahoo dot com Assigned:
Status: Not a bug Package: PDO OCI
PHP Version: Irrelevant OS: Debian 7.4
Private report: No CVE-ID: None
 [2015-02-04 17:24 UTC] amosbatto at yahoo dot com
Description:
------------
The "PDO_OCI-1.0.tgz" file for the PDO_OCI extension is not able to be decompressed.

Here is what I see on my server:
--------
# pecl download pdo_oci
WARNING: "pear/PDO_OCI" is deprecated in favor of "channel://http://www.php.net/pdo_oci/ext/pdo_oci"
downloading PDO_OCI-1.0.tgz ...
Starting to download PDO_OCI-1.0.tgz (13,679 bytes)
.....done: 13,679 bytes
File /home/user/pdo_oci/PDO_OCI-1.0.tgz downloaded
# tar xzvf PDO_OCI-1.0.tgz 
package.xml
PDO_OCI-1.0/config.m4
PDO_OCI-1.0/config.w32
PDO_OCI-1.0/pdo_oci.c
PDO_OCI-1.0/oci_driver.c
PDO_OCI-1.0/oci_statement.c
PDO_OCI-1.0/php_pdo_oci.h
PDO_OCI-1.0/php_pdo_oci_int.h
PDO_OCI-1.0/CREDITS
tar: A lone zero block at 122
----------------

Since fixed this problem by using a previous version of the PDO_OCI-1.0.tgz file, which I had downloaded before. See the attachment. In this tarball, I have fixed the config.m4 file to work with newer versions of Oracle.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-02-04 17:35 UTC] amosbatto at yahoo dot com
I tried to upload the tarball file, but it isn't allowed because it isn't a text file. (I know that you guys want patch files, but this is annoying.) If you want the tarball, it can be downloaded at:
http://www.reaccionclimatica.org/rc/PDO_OCI-1.0.tgz
 [2015-02-04 18:55 UTC] sixd@php.net
-Status: Open +Status: Not a bug
 [2015-02-04 18:55 UTC] sixd@php.net
From http://pecl.php.net/package/PDO_OCI: "This package is not maintained anymore and has been superseded."

Use the PDO_OCI that is bundled with PHP.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 13 17:01:31 2019 UTC