php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68965 Opcache could not be used in conjunction with php-fpm chroot
Submitted: 2015-01-31 19:59 UTC Modified: 2016-06-30 09:09 UTC
Votes:5
Avg. Score:5.0 ± 0.0
Reproduced:5 of 5 (100.0%)
Same Version:2 (40.0%)
Same OS:1 (20.0%)
From: exception0x876 at gmail dot com Assigned:
Status: Duplicate Package: opcache
PHP Version: 5.5.21 OS: Gentoo Linux
Private report: No CVE-ID: None
 [2015-01-31 19:59 UTC] exception0x876 at gmail dot com
Description:
------------
It caches files by its full path so if there are same file paths under different chroots (take /config.php as an example), it serves incorrect cached file. One of the possible solutions I can think of is to add some additional info for cached file (like filesize, md5sum, filesystem inode etc.)

Expected result:
----------------
Correct file served from cache for dirrefent chroots.

Actual result:
--------------
Incorrect file served from cache.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-02-11 23:22 UTC] public+php dot net at bastelstu dot be
This appears to be a duplicate of: https://bugs.php.net/bug.php?id=67141
 [2015-11-10 01:31 UTC] spamto at mailinator dot com
Hi, we are experiencing the same problem, as well as a number of other users (see bug 67481 https://bugs.php.net/bug.php?id=67481). For now we disable file opcache in chrooted environments (all of our environments) but that's a pity file opcache provides a significant improvement in performance and server load.
 [2016-06-30 09:09 UTC] requinix@php.net
-Status: Open +Status: Duplicate
 [2016-06-30 09:09 UTC] requinix@php.net
(mentioning bug #67141 for the automatic backlink)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 04 19:01:16 2020 UTC