php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68952 pecl install PDO fails
Submitted: 2015-01-29 22:42 UTC Modified: 2015-01-29 22:47 UTC
From: huda06_89 at hotmail dot com Assigned:
Status: Not a bug Package: PECL (PECL)
PHP Version: 5.6.5 OS: SUSE Enterprise Server 10 SP 4
Private report: No CVE-ID: None
 [2015-01-29 22:42 UTC] huda06_89 at hotmail dot com
Description:
------------
I ran "pecl install PDO" and it failed with the following:
I got pecl with php installation.
please advise what is the issue.. this is blocking my progress.. thank you


creating libtool
appending configuration tag "CXX" to libtool
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/sh /tmp/pear/temp/pear-build-rooteef81z/PDO-1.0.3/libtool --mode=compile cc  -I. -I/tmp/pear/temp/PDO -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-rooteef81z/PDO-1.0.3/include -I/tmp/pear/temp/pear-build-rooteef81z/PDO-1.0.3/main -I/tmp/pear/temp/PDO -I/usr/local/php/include/php -I/usr/local/php/include/php/main -I/usr/local/php/include/php/TSRM -I/usr/local/php/include/php/Zend -I/usr/local/php/include/php/ext -I/usr/local/php/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/PDO/pdo.c -o pdo.lo
mkdir .libs
 cc -I. -I/tmp/pear/temp/PDO -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-rooteef81z/PDO-1.0.3/include -I/tmp/pear/temp/pear-build-rooteef81z/PDO-1.0.3/main -I/tmp/pear/temp/PDO -I/usr/local/php/include/php -I/usr/local/php/include/php/main -I/usr/local/php/include/php/TSRM -I/usr/local/php/include/php/Zend -I/usr/local/php/include/php/ext -I/usr/local/php/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/PDO/pdo.c  -fPIC -DPIC -o .libs/pdo.o
/tmp/pear/temp/PDO/pdo.c: In function âphp_pdo_get_exception_baseâ:
/tmp/pear/temp/PDO/pdo.c:78: error: too few arguments to function âzend_exception_get_defaultâ
make: *** [pdo.lo] Error 1
ERROR: `make' failed



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-01-29 22:47 UTC] mfonda@php.net
-Status: Open +Status: Not a bug
 [2015-01-29 22:47 UTC] mfonda@php.net
PDO is now bundled with PHP -- the PECL extension should not be used anymore. For installation info, see http://php.net/manual/en/pdo.installation.php.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 11 06:01:28 2020 UTC