php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68880 searchbar switches languages
Submitted: 2015-01-21 23:17 UTC Modified: 2015-05-01 22:28 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: spydmobile at gmail dot com Assigned:
Status: Re-Opened Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2015-01-21 23:17 UTC] spydmobile at gmail dot com
Description:
------------
using the online manual site in English, the search bar changes language to french.

Test script:
---------------
example steps to reproduce:
sitting on this page: 
http://php.net/manual/en/language.oop5.cloning.php

click in the search box and type file_get_contents hit enter
you will now find yourself on this page: 
http://php.net/manual/fr/function.file-get-contents.php

You are now reading french, this happens all the time, and is incredibly frustrating when developing and having to manually edit the URL. 

IMHO this is a bug, the first page you should land at in a search should be the same language you are reading the site in in the first place. 

kalle at php dot net asked me to indicate which mirror I am using, and I really dont know, the URLs I am using are above. Further, I tried to open this as a new ticket originally but the system stopped me and said that one already existed and suggested that I use it, so I did and I afterwards was asked politely to open a new one instead of reviving a 13 year old closed one - which I have done, but I humbly suggest that the bug reporting process *NOT* offer 13 year old closed tickets to block a new one, because this is effectively the 3rd time I put all this in here because of process - just saying, many folks would have given up reporting the error long ago.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-04-15 14:14 UTC] cmb@php.net
-Status: Open +Status: Feedback
 [2015-04-15 14:14 UTC] cmb@php.net
Do you have set French as preferred language in
<http://php.net/my.php>?
 [2015-04-15 14:14 UTC] cmb@php.net
-Assigned To: +Assigned To: cmb
 [2015-04-15 15:56 UTC] spydmobile at gmail dot com
-Status: Feedback +Status: Assigned
 [2015-04-15 15:56 UTC] spydmobile at gmail dot com
cmb@php.net: No it is set to "Not Set"
 [2015-04-15 21:40 UTC] cmb@php.net
-Status: Assigned +Status: Not a bug
 [2015-04-15 21:40 UTC] cmb@php.net
Ah, thanks! Indeed, I can confirm the behavior after having unset
my preferred language.

However, I think that's more of a feature. When searching, the
result is displayed in the language determined by the
Accept-Language header sent by the client (unless overridden by the
"My php.net" settings, and if the language is available).

If you prefer to browse php.net with another language as set in
your browser's preferences, use "My php.net" to configure it.
 [2015-04-15 21:52 UTC] cmb@php.net
-Status: Not a bug +Status: Re-Opened
 [2015-04-15 21:52 UTC] cmb@php.net
Well, after actually reading the description on "My php.net" and
doing some more tests, it appears that the LAST_LANG cookie is not
set, when following a link. That might be considered a bug --
re-opening.
 [2015-05-01 22:28 UTC] cmb@php.net
-Assigned To: cmb +Assigned To:
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 08 10:01:24 2019 UTC