php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68796 Cannot start vc11 ts version
Submitted: 2015-01-11 00:13 UTC Modified: 2015-01-16 12:35 UTC
From: o dot vinzent at uni-partners dot de Assigned:
Status: Not a bug Package: memcache (PECL)
PHP Version: 5.6.4 OS: Windows 8
Private report: No CVE-ID: None
 [2015-01-11 00:13 UTC] o dot vinzent at uni-partners dot de
Description:
------------
startung memcache_dll.dll under XAMPP Control Panel v3.2.1 creates a popup with just
'Startup:'

any ideas?
Thank you very much.
Best,
Otto


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-01-11 00:14 UTC] o dot vinzent at uni-partners dot de
-Summary: Cannot start vc11 nts version with memcache_dll.dll +Summary: Cannot start vc11 nts version
 [2015-01-11 00:14 UTC] o dot vinzent at uni-partners dot de
sorry, php_memcache.dll
 [2015-01-11 00:15 UTC] o dot vinzent at uni-partners dot de
using php_memcache-3.0.8-5.6-nts-vc11-x64.zip
from http://windows.php.net/downloads/pecl/releases/memcache/3.0.8/
 [2015-01-12 11:56 UTC] ab@php.net
-Status: Open +Status: Feedback
 [2015-01-12 11:56 UTC] ab@php.net
Is the XAMPP build vc11+x64 as well? Also, is that reproducible with the php build from windows.php.net?

Thanks.
 [2015-01-12 13:35 UTC] o dot vinzent at uni-partners dot de
-Status: Feedback +Status: Open
 [2015-01-12 13:35 UTC] o dot vinzent at uni-partners dot de
I've tried every version at http://windows.php.net/downloads/pecl/releases/memcache/3.0.8/
and not any was working right.
 [2015-01-12 16:27 UTC] ab@php.net
-Status: Open +Status: Feedback
 [2015-01-12 16:27 UTC] ab@php.net
OK, and the second question?

Thanks.
 [2015-01-12 16:41 UTC] ab@php.net
I think i see your issue now - XAMPP utilizes Apache, so it has to utilize the thread safe PHP. For one - check whether you have 64 or 32 bit PHP in there, then choose TS build of the memcache ext.

Thanks.
 [2015-01-13 11:13 UTC] o dot vinzent at uni-partners dot de
-Status: Feedback +Status: Open
 [2015-01-13 11:13 UTC] o dot vinzent at uni-partners dot de
Hi,
I've already tried TS versions for 64 bit but still get the same message.
Regarding the 2nd question I've no experience because I'm only using XAMPP at the moment and in the past there were issues using both on the same machine.
 [2015-01-13 12:02 UTC] ab@php.net
-Status: Open +Status: Feedback
 [2015-01-13 12:02 UTC] ab@php.net
But is the PHP build also 64 bit? That's what I mean. What do you see as architecture when running phpinfo() (or php -i)? Maybe you could post like first 35 lines.

Thanks.
 [2015-01-13 12:23 UTC] pajoye@php.net
ok,  your setup clearly has a config issue or you fetch the wrong binaries.

this is for bug reports, not support.

However do the following:

. download php from windows.php.net (the available 64bit one)
. download memcache matching the one you fetched (TS or NTS)
. copy the memcache DLL in the php/ext dir
. run php -n -dextension_dir=ext -dextenson=php_memcache.dll -m

You will see memcache loaded.

Now pls try that, if it works, pls ask support on the XAMPP forums.
 [2015-01-13 13:35 UTC] o dot vinzent at uni-partners dot de
-Status: Feedback +Status: Open
 [2015-01-13 13:35 UTC] o dot vinzent at uni-partners dot de
I've just done:
. download php from windows.php.net (the available 64bit one) - VC11 x86 Thread Safe (2014-Dec-18 00:01:59)
. download memcache matching the one you fetched (TS, 64bit: php_memcache-3.0.8-5.6-ts-vc11-x64.zip)
. copy the memcache DLL in the php/ext dir
. run php -n -dextension_dir=ext -dextenson=php_memcache.dll -m

result:

[PHP Modules]
bcmath
calendar
Core
ctype
date
dom
ereg
filter
ftp
hash
iconv
json
libxml
mcrypt
mhash
mysqlnd
odbc
pcre
PDO
Phar
Reflection
session
SimpleXML
SPL
standard
tokenizer
wddx
xml
xmlreader
xmlwriter
zip
zlib

[Zend Modules]
 [2015-01-13 14:02 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2015-01-13 14:02 UTC] ab@php.net
Hi,

VC11 x86 Thread Safe (2014-Dec-18 00:01:59) - this is a 32 bit build. Loading 64 bit DLL into a 32 bit binary won't work. Please use the matching versions.

Thanks.
 [2015-01-13 22:41 UTC] o dot vinzent at uni-partners dot de
-Summary: Cannot start vc11 nts version +Summary: Cannot start vc11 ts version
 [2015-01-13 22:41 UTC] o dot vinzent at uni-partners dot de
Hi,
sorry, cannot get it to work.
Created: new directory d:\dev\php
unzipped: php-5.6.4-Win32-VC11-x64.zip
unzipped: php_memcache-3.0.8-5.6-ts-vc11-x64.zip
and copied into d:\dev\php\ext
cmd with Administrator rights:
php -n -dextension_dir=ext -dextenson=php_memcache.dll -m

result:
[PHP Modules]
bcmath
calendar
Core
ctype
date
dom
ereg
filter
ftp
hash
iconv
json
libxml
mcrypt
mhash
mysqlnd
odbc
pcre
PDO
Phar
Reflection
session
SimpleXML
SPL
standard
tokenizer
wddx
xml
xmlreader
xmlwriter
zip
zlib

[Zend Modules]
 [2015-01-15 00:37 UTC] pajoye@php.net
it works like a charm.

Fix your setup. For any further support question, please refer to the XAMPP forum or the php general mailing list.

C:\apps\php564ts>php -n -d extension_dir=ext -d extension=php_memcache.dll -m      
[PHP Modules]                                                                      
bcmath                                                                             
calendar                                                                           
Core                                                                               
ctype                                                                              
date                                                                               
dom                                                                                
ereg                                                                               
filter                                                                             
ftp                                                                                
hash                                                                               
iconv                                                                              
json                                                                               
libxml                                                                             
mcrypt                                                                             
memcache                                                                           
mhash                                                                              
mysqlnd                                                                            
odbc                                                                               
pcre                                                                               
PDO                                                                                
Phar                                                                               
Reflection                                                                         
session                                                                            
SimpleXML                                                                          
SPL                                                                                
standard                                                                           
tokenizer                                                                          
wddx                                                                               
xml                                                                                
xmlreader                                                                          
xmlwriter                                                                          
zip                                                                                
zlib                                                                               
                                                                                   
[Zend Modules]
 [2015-01-16 12:35 UTC] o dot vinzent at uni-partners dot de
Hi,
I've just fixed all issues using an older version for php with XAMPP ( PHP Version 5.5.15). After install everything's working now like a charm and also memcache can now be used. It's using the 32bit libraries but shouldn't be an problem.
Thank you for your help.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Dec 07 06:03:49 2022 UTC