php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6879 Apache 1.3.12, php 4.0.2 not link with GD 1.8.3
Submitted: 2000-09-25 19:15 UTC Modified: 2000-10-05 17:09 UTC
From: bdv at sea-aeroportimilano dot it Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 4.0.2 OS: Solaris 2.6
Private report: No CVE-ID: None
 [2000-09-25 19:15 UTC] bdv at sea-aeroportimilano dot it

--> First I build GD library with these lib before:

	- Zlib 1.1.2 
	- Libpng 1.0.2 
	- jpeg-6b 

I Build all the three lib with ./configure, make, make install

and the output is in /usr/local/lib

libz.a
libpng.a

in /usr/local/bin
	cjpeg
	djpeg
	jpegtran
	rdjpgcom
	wrjpgcom

Some .h in /usr/local/include and so on in 'man'

At the end of this process I build GD Lybrary  1.8.3 with:

make 
make install

and the output of this process is:

in /usr/local/lib
	libgd.a

in /usr/local/bin
	bdftogd
	gd2copypal
	gd2topng
	gdparttopng
	gdtopng
	pngtogd
	pngtogd2
	webpng

in /usr/local/include
	gd.h
	gd_io.h
	gdcache.h
	gdfontg.h
	gdfontl.h
	gdfontmb.h
	gdfonts.h
	gdfontt.h


--> Second I build  mcrypt 2.2.7 with:

./configure
make
make install

and I have some lib and .h 

/usr/local/lib
	libmcrypt.a
	libmcrypt.la
	libmcrypt.so -> libmcrypt.so.2.0.5
	libmcrypt.so.2 -> libmcrypt.so.2.0.5
	libmcrypt.so.2.0.5


/usr/local/include
	mcrypt.h 

--> Third I build and configure apache 1.3.12 with Php 4.0.2

cd apache_1.3.12
./configure

cd php_4.0.2
./configure --with-sybase-ct=/database/sybase --with-apache=/usr/local/sorgenti/apache_1.3.12 --with-gd --with-mcrypt --enable-track-vars

make
make install


cd apache_1.3.12
./configure --prefix=/usr/local/apache --activate-module=src/modules/php4/libphp4.a
make

And the make not link because the function 'gdImageColorResolve' is contemporaneously into two library:
libgd.a and libphp4.a


What can I do ??????

cp libmodphp4.a libphp4.a
ar r libphp4.a mod_php4.o
ranlib libphp4.a
<=== src/modules/php4
<=== src/modules
cc -c  -I./os/unix -I./include   -DSOLARIS2=260 -I/usr/local/sorgenti/php-4.0.2 -I/usr/local/sorgenti/php-4.0.main -I/usr/local/sorgenti/php-4.0.2/main -I/usr/local/sorgenti/php-4.0.2/Zend -I/usr/local/sorgenti/php-4.0.2end -I/usr/local/sorgenti/php-4.0.2 -DUSE_EXPAT -I./lib/expat-lite -DNO_DL_NEEDED `./apaci` modules.c
cc -c  -I./os/unix -I./include   -DSOLARIS2=260 -I/usr/local/sorgenti/php-4.0.2 -I/usr/local/sorgenti/php-4.0.main -I/usr/local/sorgenti/php-4.0.2/main -I/usr/local/sorgenti/php-4.0.2/Zend -I/usr/local/sorgenti/php-4.0.2end -I/usr/local/sorgenti/php-4.0.2 -DUSE_EXPAT -I./lib/expat-lite -DNO_DL_NEEDED `./apaci` buildmark.c
cc  -DSOLARIS2=260 -I/usr/local/sorgenti/php-4.0.2 -I/usr/local/sorgenti/php-4.0.2/main -I/usr/local/sorgenti/p-4.0.2/main -I/usr/local/sorgenti/php-4.0.2/Zend -I/usr/local/sorgenti/php-4.0.2/Zend -I/usr/local/sorgenti/p-4.0.2 -DUSE_EXPAT -I./lib/expat-lite -DNO_DL_NEEDED `./apaci`    \
	  -o httpd buildmark.o modules.o  modules/php4/libphp4.a  modules/standard/libstandard.a  main/libmain.a  os/unix/libos.a  ap/libap.a  lib/expat-lite/libexpat.a  -R/usr/ucblib -R/usr/local/lib -R/database/sybase/lib L/usr/ucblib -L/usr/local/lib -L/database/sybase/lib -Lmodules/php4 -L../modules/php4 -L../../modules/php4 -lmphp4  -lpam  -ldl -linsck -ltcl -lintl -lcomn -lct -lcs -lmcrypt -lmcrypt -lgd -lresolv -lresolv -lm -ldl -lcrt -lnsl -lsocket  -lsocket  -lsocket -lnsl
	  ld: fatal: symbol `gdImageColorResolve' is multiply defined:
			  (file modules/php4/libphp4.a(gd.o) and file /usr/local/lib/libgd.a(gd.o));
			  ld: fatal: File processing errors. No output written to httpd
			  *** Error code 1
			  make: Fatal error: Command failed for target `target_static'
			  Current working directory /usr/local/sorgenti/apache_1.3.12/src
			  *** Error code 1
			  make: Fatal error: Command failed for target `build-std'
			  Current working directory /usr/local/sorgenti/apache_1.3.12
			  *** Error code 1
			  make: Fatal error: Command failed for target `build'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-09-27 20:47 UTC] bdv at sea-aeroportimilano dot it
Under Solari 2.6 in the shell script configure is not defined GDIMAGECOLORRESOLVE so the function ImageColorResolve () is at the same time in the file gd.c in php4/ext/gd/gd.c and gd-1.8.3/gd.c

The problem is that the HAVE_GDIMAGECOLORRESOLVE should have
been defined by configure. It haven't.
 [2000-10-05 17:08 UTC] bdv at sea-aeroportimilano dot it
I have mistaken all!!! 
My error was initial, in fact from PHP functions GD did not work. 
The zlib and libpng they must be compiled dynamic with 
/configure -- shared 
 
and then PHP goes shaped like this:
 
./configure --with-apache=/usr/local/sorgenti/apache_1.3.12
            --with-sybase-ct=/database/sybase
            --with-zlib-dir=shared
            --with-jpeg-dir=/usr/local/bin
            --with-gd=/usr/local
            --with-mcrypt
 
 
and all the things go alone to place 
 
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Mar 03 20:01:29 2024 UTC