php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68789 Cannot compile (Request new release)
Submitted: 2015-01-10 15:07 UTC Modified: 2017-04-01 20:34 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: gmblar+php at gmail dot com Assigned:
Status: Wont fix Package: idn (PECL)
PHP Version: 5.6.4 OS: MacOSX 10.10.1
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2015-01-10 15:07 UTC] gmblar+php at gmail dot com
Description:
------------
The file

http://svn.php.net/viewvc/pecl/idn/tags/RELEASE_0_2_0/idn.c?revision=272895&view=markup#l221

contains:

function_entry idn_functions[] = {

but should contain:

zend_module_entry idn_module_entry = {

what was already fixed in trunk 3 years ago

http://svn.php.net/viewvc/pecl/idn/trunk/idn.c?revision=319831&view=markup#l223

please create a new release from trunk.


Test script:
---------------
$ sudo pecl install idn-beta

downloading idn-0.2.0.tgz ...
Starting to download idn-0.2.0.tgz (6,313 bytes)
.....done: 6,313 bytes
3 source files, building
running: phpize
Configuring for:
PHP Api Version:         20131106
Zend Module Api No:      20131226
Zend Extension Api No:   220131226
GNU libidn installation dir? [autodetect] : /opt/local


Actual result:
--------------
cc -I. -I/private/tmp/pear/temp/idn -DPHP_ATOM_INC -I/private/tmp/pear/temp/pear-build-rootQa7FOI/idn-0.2.0/include -I/private/tmp/pear/temp/pear-build-rootQa7FOI/idn-0.2.0/main -I/private/tmp/pear/temp/idn -I/opt/local/include/php56/php -I/opt/local/include/php56/php/main -I/opt/local/include/php56/php/TSRM -I/opt/local/include/php56/php/Zend -I/opt/local/include/php56/php/ext -I/opt/local/include/php56/php/ext/date/lib -I/opt/local/include -I/opt/local/include -DHAVE_CONFIG_H -g -O2 -c /private/tmp/pear/temp/idn/idn.c  -fno-common -DPIC -o .libs/idn.o
/private/tmp/pear/temp/idn/idn.c:221:1: error: unknown type name 'function_entry'
function_entry idn_functions[] = {
^
1 error generated.
make: *** [idn.lo] Error 1
ERROR: `make' failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-01-20 22:49 UTC] fransecs at gmail dot com
gmblar I suppose you mean to replace:

function_entry idn_functions[] = {

with

zend_function_entry idn_functions[] = {

BUT when done so and idn.so is enabled in apache's php.ini, PHP breaks:

PHP Warning:  Function registration failed - duplicate name - idn_to_ascii in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name - idn_to_utf8 in Unknown on line 0
PHP Warning:  idn: Unable to register functions, unable to load in Unknown on line 0
Segment Violation

Should I enable idn.so elsewhere (cgi/cli/fpm)?
 [2015-01-20 23:36 UTC] gmblar+php at gmail dot com
Only enable idn.so or intl.so, because both extensions contains the idn functions. http://php.net/manual/ref.intl.idn.php
 [2015-01-21 08:54 UTC] fransecs at gmail dot com
Thanks gmblar, that was the reason for the error. I'll leave intl.so as per your suggestion.
 [2017-04-01 20:34 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 20:34 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2009, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri May 29 18:01:25 2020 UTC