php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68696 SQLSTATE[IM001]: Driver does not support this function: driver doesn't support
Submitted: 2014-12-30 06:17 UTC Modified: 2014-12-30 06:59 UTC
From: kuldeep dot patel at kelltontech dot com Assigned:
Status: Not a bug Package: PDO DBlib
PHP Version: Irrelevant OS: Red Hat Linux 6.5
Private report: No CVE-ID: None
 [2014-12-30 06:17 UTC] kuldeep dot patel at kelltontech dot com
Description:
------------
I am using CakePHP2.5+RedHatLinux6.5+Apache+MSSQL2012+PHP5.3.3. I am able to make a connection with the Database using freetds 0.91. But unable to get any query result. Whenever we try, we are getting a nothing but a warning message :

"PDOStatement::getColumnMeta(): SQLSTATE[IM001]: Driver does not support this function: driver doesn't support meta data [CORE/Cake/Model/Datasource/Database/Sqlserver.php"

We have successfully run queries from our local machine which uses Ubuntu+php5.5.

Please Help.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-12-30 06:59 UTC] aharvey@php.net
-Status: Open +Status: Not a bug -Package: PDO related +Package: PDO DBlib
 [2014-12-30 06:59 UTC] aharvey@php.net
PDO's dblib driver didn't support column metadata in PHP 5.3. (As the documentation says at http://php.net/pdostatement.getcolumnmeta, not all drivers implement that functionality.)

PHP 5.4 added support in the dblib driver for column metadata, which is why it works on PHP 5.5.

This is expected behaviour: closing not a bug. If you need further support on this, you might want to try one of PHP's or CakePHP's support channels.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Nov 14 11:01:25 2018 UTC