php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68630 "ALERT: oops, unknown child (...) exited with code 0."
Submitted: 2014-12-19 15:27 UTC Modified: 2015-02-10 01:15 UTC
From: dz at heroku dot com Assigned:
Status: Closed Package: FPM related
PHP Version: 5.6.4 OS: Ubuntu 14.04
Private report: No CVE-ID: None
 [2014-12-19 15:27 UTC] dz at heroku dot com
Description:
------------
[19-Dec-2014 14:27:38.971730] NOTICE: pid 106, fpm_unix_conf_wp(), line 128: [pool www] 'user' directive is ignored when FPM is not running as root
[19-Dec-2014 14:27:38.971730] NOTICE: pid 106, fpm_unix_conf_wp(), line 128: [pool www] 'user' directive is ignored when FPM is not running as root
[19-Dec-2014 14:27:38.973187] DEBUG: pid 106, fpm_scoreboard_init_main(), line 40: got clock tick '100'
[19-Dec-2014 14:27:38.973690] DEBUG: pid 106, fpm_event_init_main(), line 337: event module is epoll and 11 fds have been reserved
[19-Dec-2014 14:27:38.973912] NOTICE: pid 106, fpm_init(), line 85: fpm is running, pid 106
[19-Dec-2014 14:27:38.976294] DEBUG: pid 106, fpm_children_make(), line 421: [pool www] child 117 started
[19-Dec-2014 14:27:38.978554] DEBUG: pid 106, fpm_children_make(), line 421: [pool www] child 118 started
[19-Dec-2014 14:27:38.978608] DEBUG: pid 106, fpm_event_loop(), line 366: 5992 bytes have been reserved in SHM
[19-Dec-2014 14:27:38.978616] NOTICE: pid 106, fpm_event_loop(), line 367: ready to handle connections
...
[19-Dec-2014 14:44:20.240893] DEBUG: pid 106, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 3 spare children, 3 running children. Spawning rate 1
[19-Dec-2014 14:44:21.256687] DEBUG: pid 106, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 3 active children, 0 spare children, 3 running children. Spawning rate 1
[19-Dec-2014 14:44:21.279763] DEBUG: pid 106, fpm_children_make(), line 421: [pool www] child 135 started
[19-Dec-2014 14:44:21.279813] DEBUG: pid 106, fpm_pctl_perform_idle_server_maintenance(), line 428: [pool www] 1 child(ren) have been created dynamically
[19-Dec-2014 14:44:22.258713] DEBUG: pid 106, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 4 spare children, 4 running children. Spawning rate 2
[19-Dec-2014 14:44:22.279948] DEBUG: pid 106, fpm_event_loop(), line 419: event module triggered 1 events
[19-Dec-2014 14:44:22.280206] DEBUG: pid 106, fpm_event_loop(), line 419: event module triggered 1 events
[19-Dec-2014 14:44:22.285477] DEBUG: pid 106, fpm_got_signal(), line 76: received SIGCHLD
[19-Dec-2014 14:44:22.285598] ALERT: pid 106, fpm_children_bury(), line 295: oops, unknown child (113) exited with code 0. Please open a bug report (https://bugs.php.net).
[19-Dec-2014 14:44:22.285672] DEBUG: pid 106, fpm_children_bury(), line 254: [pool www] child 117 has been killed by the process management after 1003.309423 seconds from start
[19-Dec-2014 14:44:22.285715] DEBUG: pid 106, fpm_event_loop(), line 419: event module triggered 1 events
[19-Dec-2014 14:44:23.260780] DEBUG: pid 106, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 3 spare children, 3 running children. Spawning rate 1
[19-Dec-2014 14:44:24.263014] DEBUG: pid 106, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 3 spare children, 3 running children. Spawning rate 1
[19-Dec-2014 14:44:25.264402] DEBUG: pid 106, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 3 spare children, 3 running children. Spawning rate 1
[19-Dec-2014 14:44:26.266396] DEBUG: pid 106, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 3 spare children, 3 running children. Spawning rate 1
[19-Dec-2014 14:44:27.267484] DEBUG: pid 106, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 3 spare children, 3 running children. Spawning rate 1

Could this be some kind of race condition in fpm_got_signal() and fpm_children_bury()?

The weird thing is that the lowest child PID spawned was 117.

Any idea where this is coming from or how to investigate? I cannot generate a GDB backtrace unfortunately.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-12-19 15:30 UTC] dz at heroku dot com
Should have mentioned:

pm = dynamic
pm.max_children = 5
pm.start_servers = 2
pm.min_spare_servers = 1
pm.max_spare_servers = 3
 [2015-02-10 01:15 UTC] dz at heroku dot com
-Status: Open +Status: Closed
 [2015-02-10 01:15 UTC] dz at heroku dot com
It looks like this is caused by the new relic daemon spawning as a child of an FPM process and then detaching itself.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jul 06 03:01:28 2020 UTC