php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Sec Bug #68588 during making a call to paypal API giving User Notice: Recv failure
Submitted: 2014-12-11 05:31 UTC Modified: 2014-12-30 08:30 UTC
From: maheshn407 at gmail dot com Assigned:
Status: Not a bug Package: cURL related
PHP Version: 5.5.19 OS: ubuntu 13.10 32 bit OS
Private report: No CVE-ID: None
 [2014-12-11 05:31 UTC] maheshn407 at gmail dot com
Description:
------------
$ch = curl_init();
$url = 'api-3t.sandbox.paypal.com'.'?'. http_build_query($params);
			
		curl_setopt_array($ch, array(
		CURLOPT_URL => $url,
		CURLOPT_RETURNTRANSFER => 1
		)
		);
			
		if(!$response = curl_exec($ch))
		{
			trigger_error(curl_error($ch));
		}
			
		curl_close($ch);
		parse_str($response, $arrResponse);
		print_r($arrResponse); exit;

Test script:
---------------
working on paypal integartion using php....during making a call to paypal sandbox account API i am gettinng Recv Failure error....i am confusing this error is related to coding or ssl and firewall

Please help me out for this problem.

Expected result:
----------------
after authenticating to paypal it will return ACk = Success

Actual result:
--------------
after authenticating to paypal it will return ACk = Success

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-12-30 08:30 UTC] stas@php.net
-Status: Open +Status: Not a bug
 [2014-12-30 08:30 UTC] stas@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Oct 22 13:01:29 2019 UTC