php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #68564 Apparent inconsistency in the GC page
Submitted: 2014-12-08 02:38 UTC Modified: 2021-09-23 16:34 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: dominic_mayers at yahoo dot com Assigned: cmb (profile)
Status: Closed Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2014-12-08 02:38 UTC] dominic_mayers at yahoo dot com
Description:
------------
---
From manual page: http://www.php.net/features.gc.refcounting-basics
---
In the example 1, we have : Note that if "refcount" is 1, "is_ref" is always FALSE. What "always" means here is definitively not clear, because later in example 9 we have : 1 => (refcount=1, is_ref=1)=...


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-07-19 15:54 UTC] cmb@php.net
-Status: Open +Status: Verified
 [2021-07-19 15:54 UTC] cmb@php.net
> Note that if "refcount" is 1, "is_ref" is always FALSE.

Indeed, this is not correct.  What the documentation likely wants
to express is that references with refcount 1 are treated as if
they're were no references.
 [2021-09-23 16:34 UTC] cmb@php.net
-Summary: Apparent inconsistency in the page. +Summary: Apparent inconsistency in the GC page -Assigned To: +Assigned To: cmb
 [2021-09-23 16:40 UTC] git@php.net
Automatic comment on behalf of cmb69
Revision: https://github.com/php/doc-en/commit/39cd8c54e8159361d33f33837c904bf6cfb6c055
Log: Fix #68564: Apparent inconsistency in the GC page
 [2021-09-23 16:40 UTC] git@php.net
-Status: Verified +Status: Closed
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Oct 25 08:03:33 2021 UTC