php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68543 syslog adds description for Event ID x from source y cannot be found
Submitted: 2014-12-03 15:52 UTC Modified: 2014-12-04 08:05 UTC
From: php at sanexeh dot nl Assigned:
Status: Not a bug Package: IIS related
PHP Version: Irrelevant OS: Windows 2012 R2
Private report: No CVE-ID: None
 [2014-12-03 15:52 UTC] php at sanexeh dot nl
Description:
------------
On Microsoft Windows OS (at least 2003 and newer) an invalid Event ID is passed when creating an event log (Event Viewer => Windows Logs => Application)


Test script:
---------------
php.exe -n -r "syslog(LOG_CRIT, 'hello there');

Expected result:
----------------
php[5500]
hello there

Actual result:
--------------
The description for Event ID 4 from source PHP-5.5.19 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event: 

php[5500]
hello there


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-12-03 15:54 UTC] php at sanexeh dot nl
Might be duplicate for https://bugs.php.net/bug.php?id=8314 and https://bugs.php.net/bug.php?id=23015. Those are about Windows 2000. I'm unable to reproduce on that OS anymore ;).
 [2014-12-04 08:05 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2014-12-04 08:05 UTC] ab@php.net
The solution lays unfortunately not in PHP. The app has to be registered with windows. A reg file can be generated automatically when compiling from source and doing "nmake install". But for a zipball this has to be done manually, a template is here http://lxr.php.net/xref/PHP_5_5/win32/syslog.reg . The reason why it can't be done automatically is that the access to that registry key cannot be guaranteed. That's what also Wez mentioned in his comment in bug #8314.

Thanks.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Sep 29 08:01:24 2020 UTC