PHP :: Bug #68519 :: requesting new pecl release
php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68519 requesting new pecl release
Submitted: 2014-11-27 22:46 UTC Modified: 2017-10-24 04:25 UTC
Votes:25
Avg. Score:4.4 ± 1.1
Reproduced:19 of 22 (86.4%)
Same Version:14 (73.7%)
Same OS:6 (31.6%)
From: tyrael@php.net Assigned:
Status: Suspended Package: mysqlnd_ms (PECL)
PHP Version: 5.6.3 OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2014-11-27 22:46 UTC] tyrael@php.net
Description:
------------
hi,

the latest (1.6.0 alpha) release is not compatible with PHP 5.6: the signature of zval_to_mysqlnd got changed in 5.6, and while this was fixed in trunk these are not present in the latest release.

ps: there was a missing semicolon in the current trunk which prevented the compilation, but after fixing it, the build succeeds for 5.6.

it would be nice if you could do an 5.6 compatible pecl release!



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-11-28 10:26 UTC] tyrael@php.net
-Assigned To: +Assigned To: uw
 [2017-03-02 20:44 UTC] alex at goldsilver dot com
this missing semi-colon hasn't been addressed in 2 years. hugely valuable plug-in preventing 5.6 and 7.0 upgrades. Any chance a PR can be added to this ticket so this is fixed and start offering this PECL extension again?
 [2017-10-24 04:25 UTC] kalle@php.net
-Status: Assigned +Status: Suspended -Assigned To: uw +Assigned To:
 [2017-10-24 04:25 UTC] kalle@php.net
I'm gonna suspend this report as the mysqlnd_ms had not a release since 2013 or active commit activity since then, if activity comes back to this package, it should be re-opened
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Tue Aug 14 08:01:25 2018 UTC