php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68502 execution sequence is wrong on the ISAPI
Submitted: 2014-11-26 08:58 UTC Modified: 2014-11-26 17:34 UTC
From: hewei986532 at sina dot com Assigned:
Status: Not a bug Package: *Web Server problem
PHP Version: 5.4Git-2014-11-26 (Git) OS: centos
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: hewei986532 at sina dot com
New email:
PHP Version: OS:

 

 [2014-11-26 08:58 UTC] hewei986532 at sina dot com
Description:
------------
The result is wrong when access test script which is Similar to the Singleton.php example file  In the browser to access .Then it's correct on the cli.


Pthread is a great progress for phper。

Test script:
---------------
<?php

class test {
    public static function hello()
    {
        return true;
    }
}

if (test::hello()) {
    printf("...1\n");
    if (test::hello()) {
        printf("...2\n");
    }
}

class UserThread extends Thread {

    public function run () {
        if (test::hello()) {
            printf("...3\n");
            if (test::hello()) {
                printf("...4\n");
            }
        }


    }
}
$thread = new UserThread();
$thread->start();




Expected result:
----------------
...1 ...2 ...3 ...4 

Actual result:
--------------
...3 ...4 ...1 ...2 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-11-26 17:34 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2014-11-26 17:34 UTC] aharvey@php.net
Please reopen this bug against the pthreads extension, rather than PHP itself: https://bugs.php.net/report.php?package=pthreads
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu May 13 20:01:24 2021 UTC