php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68476 [PATCH] configure does not recognise libenchant version
Submitted: 2014-11-21 21:02 UTC Modified: 2015-07-05 08:22 UTC
From: gunter at grodotzki dot co dot za Assigned: pajoye (profile)
Status: Closed Package: Enchant related
PHP Version: 5.6 OS: Darwin 14
Private report: No CVE-ID: None
 [2014-11-21 21:02 UTC] gunter at grodotzki dot co dot za
Description:
------------
enchant includes two (still undocumented) functions since version 1.1.0:
* enchant_broker_set_dict_path
* enchant_broker_get_dict_path

Both of them only get activated if libenchant >= 1.5.0. Unfortunately there seems to be an error in the configure script that will fail the version detection, even if a newer libenchant version is installed.

I tested it on OSX, but the problem might exist on other Unix/Linux systems.

The fix seems to be trivial so I am adding a patch to it. A more experienced developer can surely see much quicker if the patch is doing good or bad, than me.

Test script:
---------------
<?php

$broker = enchant_broker_init();

var_dump(enchant_broker_set_dict_path($broker, ENCHANT_MYSPELL, __DIR__));


Expected result:
----------------
bool(true)

Actual result:
--------------
bool(false)

Patches

configure-enchant-version (last revision 2014-11-21 21:03 UTC by gunter at grodotzki dot co dot za)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-02-17 01:54 UTC] felipe@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: pajoye
 [2015-07-05 08:22 UTC] stas@php.net
-Status: Assigned +Status: Closed -PHP Version: Irrelevant +PHP Version: 5.6
 [2015-07-05 08:22 UTC] stas@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.

Patch merged in 5.6 and master.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Sep 27 19:01:23 2020 UTC