php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #68354 Compatibility broken, documentation outdated
Submitted: 2014-11-05 17:52 UTC Modified: 2016-06-07 14:06 UTC
From: kastaneda at gmail dot com Assigned: mike (profile)
Status: Closed Package: pecl_http (PECL)
PHP Version: 5.6.2 OS: Debian GNU/Linux
Private report: No CVE-ID: None
 [2014-11-05 17:52 UTC] kastaneda at gmail dot com
Description:
------------
As far as I know, this PECL extension (pecl_http) had changed it's API in version 2. I checked it on version 2.1.3 and I can see that old functions is not working anymore.

---
From manual page: http://www.php.net/function.http-build-url
---


Test script:
---------------
<?php

// This should work, according to documentation
// But this function is undefined in pecl_http version 2.1.3
echo http_build_url();


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-11-05 18:49 UTC] mike@php.net
-Status: Open +Status: Suspended
 [2014-11-05 18:49 UTC] mike@php.net
See here for the notice:
http://at1.php.net/manual/en/intro.http.php
 [2015-08-06 20:35 UTC] cmb@php.net
-Assigned To: +Assigned To: mike
 [2015-08-06 20:35 UTC] cmb@php.net
Mike, are there plans to move the http v2 documentation into the php.net manual?
 [2015-08-07 06:05 UTC] mike@php.net
No definitive plans.

Currently all my docs are located at https://mdref.m6w6.name/

I once had an offer from someone to convert them (pecl_http v2), but I have not heard anything for a few months.
 [2016-06-07 14:06 UTC] cmb@php.net
-Status: Suspended +Status: Closed
 [2016-06-07 14:06 UTC] cmb@php.net
As the documentation has already been removed from the PHP manual,
I'm closing this ticket.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Apr 15 00:01:28 2024 UTC