php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68315 pecl install bcompiler err
Submitted: 2014-10-28 03:48 UTC Modified: 2015-08-03 21:11 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: kissthink at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: bcompiler (PECL)
PHP Version: 5.5Git-2014-10-28 (Git) OS: ubuntu
Private report: No CVE-ID: None
 [2014-10-28 03:48 UTC] kissthink at gmail dot com
Description:
------------
install bcomiler err 

pecl install bcompiler  

/tmp/pear/temp/bcompiler/php_bcompiler.c:635:33: error: 'zend_class_entry' has no member named 'filename'
    if (zc->filename && strcmp(zc->filename, real_path) == 0)
                                 ^
make: *** [php_bcompiler.lo] Error 1
ERROR: `make' failed


Linux  3.13.0-37-generic #64-Ubuntu SMP Mon Sep 22 21:28:38 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux


php -v
PHP 5.5.9-1ubuntu4.4 (cli) (built: Sep  4 2014 06:56:34) 
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
    with Zend OPcache v7.0.3, Copyright (c) 1999-2014, by Zend Technologies


Test script:
---------------
pecl install bcompiler  




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-08-03 21:11 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2015-08-03 21:11 UTC] cmb@php.net
Actually, this is a duplicate of bug #60618.
 [2015-08-03 21:11 UTC] cmb@php.net
-Package: PECL +Package: bcompiler
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jan 17 23:03:42 2022 UTC