php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68272 Installation of pecl package apcu fails clearly because of missing dependencies
Submitted: 2014-10-20 23:46 UTC Modified: 2014-10-21 06:49 UTC
From: teo8976 at gmail dot com Assigned:
Status: Not a bug Package: PECL (PECL)
PHP Version: 5.6.2 OS: debian 7
Private report: No CVE-ID: None
 [2014-10-20 23:46 UTC] teo8976 at gmail dot com
Description:
------------
Automatically managing dependencies is all a package system is about, right?
It is supposed to avoid you the hassle of figuring out each and every piece that you need to install, and do it for you.



Test script:
---------------
So, I first installed php5, php-pear and php5-dev via apt-get install.

Then I ran:
  pecl install apcu



Expected result:
----------------
should have installed apcu and whatever it depends on.

Actual result:
--------------
At first I got an error when it got to "make", because make itself was not installed. Ridiculous (if pecl needs it, it should have been already installed).


So I installed make, but then I get this other error:

In file included from /tmp/pear/temp/apcu/apc.c:44:0:
/usr/include/php5/ext/pcre/php_pcre.h:29:18: fatal error: pcre.h: No such file or directory
compilation terminated.
make: *** [apc.lo] Error 1
ERROR: `make' failed


So now I guess I am supposed to figure out what's this "pcre" extension whose "dev" package I probably need (I notice it's missing a .h file), and then go for the next error due to the next missing dependency.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-10-21 04:42 UTC] remi@php.net
This is not a APCU bug, but a packaging bug (debian).

APCU doesn't directly include pcre.h, and can't be aware if PHP is build with system of bundled libpcre.

Notice, AFAIK this have be fix by debian packager (but can't say in which version)
 [2014-10-21 06:49 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2014-10-21 06:49 UTC] ab@php.net
@teo8976 PECL will principally not install any system packages. Debian's package system is APT, not PECL. Just as Remi says. Otherwise PECL would have to catch any non homogenous behaviors on various distros, which were kinda more work than writing an extension it tries to install :) So this is an issue of PECL adoption in Debian, you should file a bug there.

Cheers.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Sep 26 06:01:23 2020 UTC