php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #68256 data types
Submitted: 2014-10-18 05:26 UTC Modified: 2014-10-18 07:03 UTC
From: antivir88 at mail dot ru Assigned:
Status: Not a bug Package: PHP Language Specification
PHP Version: Irrelevant OS: any
Private report: No CVE-ID: None
 [2014-10-18 05:26 UTC] antivir88 at mail dot ru
Description:
------------
Please add data types for default types, for a type defenitions in functions and methods.

For more, please view code:

Test script:
---------------
function abc (string $asd, array $adsa, int $asda, bool $erw)

//etc. (in this definition the valid only arra parameter)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-10-18 07:03 UTC] stas@php.net
-Status: Open +Status: Not a bug
 [2014-10-18 07:03 UTC] stas@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

This is not a standards issue. Standard describes existing language capabilities. New ones should be proposed via RFC (see wiki.php.net/rfc) and community discussion on the internals list.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 20 02:03:37 2021 UTC