php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #68202 equivalent to persistent_compile_file to a string
Submitted: 2014-10-09 20:39 UTC Modified: 2014-10-09 23:03 UTC
From: dmorilha at gmail dot com Assigned:
Status: Not a bug Package: opcache
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2014-10-09 20:39 UTC] dmorilha at gmail dot com
Description:
------------
Would it be possible to expose a function similar to persistent_compile_file which accepts a string instead of a pointer to zend_file_handle?

I would like to offer a require statement which accept multiple arguments, concatenate their content and add the result into the opcache.

It looks like multiple requires perform slower when compared with a single require with all the code merged


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-10-09 21:59 UTC] johannes@php.net
-Status: Open +Status: Not a bug
 [2014-10-09 21:59 UTC] johannes@php.net
A zend_file_handle can describe a memory mapped file. See https://github.com/johannes/pconn-sapi/blob/master/pconnect-sapi.c#L281 for an example.
 [2014-10-09 23:03 UTC] dmorilha at gmail dot com
thanks johannes
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 14:01:26 2020 UTC