php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68142 SoapServer paste in respnse HTTP_RAW_POST_DATA deprecated notice
Submitted: 2014-10-03 13:15 UTC Modified: 2014-10-17 11:22 UTC
From: michalosoft at gmail dot com Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 5.6.1 OS: CentOS
Private report: No CVE-ID: None
 [2014-10-03 13:15 UTC] michalosoft at gmail dot com
Description:
------------
After upgrade from version 5.5.x to 5.6.1 SoapServer return in response

Fatal error: Uncaught SoapFault exception: [Client] looks like we got no XML document

caused by notice HTTP_RAW_POST_DATA deprecated in XML response data, but i dont use HTTP_RAW_POST_DATA nowhere in the script


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-10-17 11:22 UTC] tyrael@php.net
-Status: Open +Status: Not a bug
 [2014-10-17 11:22 UTC] tyrael@php.net
setting  always_populate_raw_post_data to -1 should remove the warning.
you can read more about here:
http://php.net/manual/en/ini.core.php#ini.always-populate-raw-post-data
btw. usually it is a good practice to have display_errors = Off in production.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 20 13:03:32 2021 UTC