php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #68109 Add MurmurHash V3
Submitted: 2014-09-26 19:47 UTC Modified: 2020-10-31 15:48 UTC
Votes:26
Avg. Score:4.5 ± 0.8
Reproduced:20 of 20 (100.0%)
Same Version:11 (55.0%)
Same OS:10 (50.0%)
From: da at lessconfused dot com Assigned: ab (profile)
Status: Closed Package: *Encryption and hash functions
PHP Version: Irrelevant OS: NA
Private report: No CVE-ID: None
 [2014-09-26 19:47 UTC] da at lessconfused dot com
Description:
------------
Murmurhash3 is getting a lot of use on the web due to its fast hashing capabilities which is important for a lot of applications.  Can we include it as a hash function?  MD5 is getting less useful by the day and a fast hashing mechanism has become very important.


Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-09-29 21:55 UTC] da at lessconfused dot com
xxHash would also be desirable.
 [2015-05-28 12:13 UTC] cmb@php.net
Related to request #62063.
 [2020-09-02 14:44 UTC] ab@php.net
The following pull request has been associated:

Patch Name: hash: Add MurmurHash3 with streaming support
On GitHub:  https://github.com/php/php-src/pull/6059
Patch:      https://github.com/php/php-src/pull/6059.patch
 [2020-10-31 15:48 UTC] ab@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: ab
 [2020-10-31 15:48 UTC] ab@php.net
PR merged.

Thanks.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Aug 14 04:05:44 2022 UTC