php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #68084 Unable to load dynamic library
Submitted: 2014-09-23 11:44 UTC Modified: 2014-09-25 18:46 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: rainer dot stuelp at outlook dot de Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: master-Git-2014-09-23 (snap) OS: Windows 8.1 64bit
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rainer dot stuelp at outlook dot de
New email:
PHP Version: OS:

 

 [2014-09-23 11:44 UTC] rainer dot stuelp at outlook dot de
Description:
------------
I have installed the following software:

- Windows 8.1 64 bit
- Apache 2.4.10 x64 VC11
- PHP 5.7.0-dev (same error with 5.6.0 VC11 x64)

In the php.ini I have activate the interbase extension. I copied the FBCLIENT.dll to my PHP directory (same directory where the php.exe is stored) and added this PHP directory to my PATH setting.

From a command box I run php.exe and I got the following output on screen:

PHP Warning: PHP Startup: Unable to load dynamic library ´D:\WebServer\php\ext\php_interbase.dll´ - %1 is not a valid win32 application
in Unknown on line 0

When I use the same version of Apache and PHP, but both as 32bit application (X86), and the same ini files, it works fine and I can access with a php-file to the firebird database.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-09-25 18:46 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2014-09-25 18:46 UTC] ab@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

I'm not sure why you mention 5.7 as there is no such branch, furthermore AFAIR ext/interbase isn't ported there yet. You probably mean 7-dev which master is now.

This anyway doesn't change the matter as you've got the same with 5.6 x64 and the issue is not far to seek. Seems that you're using the dependency DLL compiled for 32 bit, they obviously can't load into a 64 bit binary. Please obtain the correct dependency DLL and this will fix the issue.

Thanks.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jul 13 19:01:30 2024 UTC